1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

No Sound through HDMI with Windows Media Player Classic

Discussion in 'Multimedia' started by williamc, May 17, 2012.

Thread Status:
Not open for further replies.
Advertisement
  1. williamc

    williamc Thread Starter

    Joined:
    Jul 19, 2004
    Messages:
    72
    Hello,
    I'm running the KLite Codec pack with Windows Media Player Classic. For the past year, there haven't been any problems. But now I don't get any sound when I use WMPC with HDMI output for sound. I can use Windows Media Player and VLC without any issues. Also, WMPC works if I change the output to my computer speakers. I just started experiencing this issue, and I haven't been able to resolve it. I've forced the output to the receiver (HDMI), changed channel configurations, used different types of media, etc. I'm at a loss. Any help is appreciated.

    Specs:
    Window 7 Ultimate
    NVidia GeForce GT 520 (for video and sound over HDMI)
    NVidia High Definition Audio (HDMI) <---- This only works with VLC and Windows Media Player
    Speakers (High Definition Audio Device) <----- this one works with all media players, its the build in computer speakers over audio cable.
     
  2. Oddba11

    Oddba11 Jim

    Joined:
    May 12, 2011
    Messages:
    4,648
    You should be able to set the HDMI output as the default source in the audio setup. That will send ALL Wiindows audio out the HDMI port.

    You can also select which audio chipset is used within the media player itself. That option will only send the media player audio out the HDMI port.
     
  3. williamc

    williamc Thread Starter

    Joined:
    Jul 19, 2004
    Messages:
    72
    That's the way its set. Seems to be a problem with Windows Media Player Classic and its Codecs. Reinstall time. :(
     
  4. Elvandil

    Elvandil

    Joined:
    Aug 1, 2003
    Messages:
    51,988
    What is the audio output set to in MPC?
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1053561