1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

No taskbar, cannot start remote procedure call, system restore doesn't run

Discussion in 'Windows XP' started by FugacityMan, Jun 27, 2011.

Thread Status:
Not open for further replies.
  1. FugacityMan

    FugacityMan Thread Starter

    Joined:
    Dec 26, 2005
    Messages:
    4
    Hello,

    I'm running a Dell Inspiron 600m with Windows XP, SP3.

    I turned on my computer on Friday morning to find that my Network Connections windows was entirely blank - not showing that my local and wireless connection were broken, but rather not registering them at all. My local connection had been inactive for a while due to an internal issue, but I had resolved it the day before by purchasing and installing StarTech.com's USB 2.0 to 10/100 Mbps Ethernet adapter, which worked perfectly for one day until this problem arose (it may have been the first time that I restarted the computer after the adapter was installed - don't recall exactly - although I restarted the computer several times over the course of the installation process). I deleted and reinstalled all of my network drivers - for my broken ethernet connection, for the adapter, and for my wireless connection - but nothing changed.

    Upon navigating my system, I discovered a litany of other problems with it:

    * Whenever I booted up, my taskbar would be locked into the position where all that's visible is a thin line at the bottom of the screen (one step beyond the default). I worked around this problem by adding a toolbar, which caused the taskbar to expand, and then removing it, following which the taskbar stayed in place. The toolbar font looks different, perhaps somewhat similar to that of an old version of Windows.

    * When I ran a Symantec quick scan, nothing came up. When I ran a full scan, the program closed itself midway through, and would not run again.

    * I had a copy of the MalwareBytes installer on a memory stick, and used it to install the program on my computer, but when I attempted to run it, came up with "run time error 372. Failed to load control vbalGrid from vbalsgrid6.ocx. Your version of vbalsgrid6.ocx may be outdated. Please make sure you are using the control that was provided with your application." Reinstalling the program produced the same error.

    * On my log-in screen, an account that I had never seen before (password-protected, no less), "Us" appeared. When I selected User Profiles from the control panel, the window was completely empty, and no user folder corresponding to this account appears in my C:\Documents and Settings folder.

    * System Restore is non-functional.

    * When I went to the my administrative tools/services window, there were a variety of services that should have been running that were not. Most of them seemed to be depended on the Remote Procedure Control (RPC) Service, which would not start.

    * When I glanced at my registry, I saw that my LEGACY_RPCSS registry subkey was missing completely from my hardware profiles folder within the registry. Not sure what this is supposed to control, but my preliminary research indicated that changing something within this subkey has fixed similar problems, only that I don't seem to have that subkey.

    * Drag-and-drop and paste functionalities for files are disabled.

    I'm not sure if this was caused by malware or by something else, but it's fairly worrisome. I'm curious if I should be concerned that, if there is something on my system, it could have infected my memory stick with something that could infect a second system that it's plugged into, in the event that I'm advised to download programs for use in further troubleshooting/remediating this problem (given that I have no internet access).

    To add a further twist, my arrow keys have been non-functional for a while (victims of a poorly located spill). Instead of connecting a replacement keyboard to my laptop, I remedied the issue using SharpKeys, but the downside of this issue is that I have not been able to figure out how to access Safe Mode without using the arrow keys (as the remapping does not seem to take effect until the system start-up is complete). If I would need to go through Safe Mode to troubleshoot/solve the issue, I would need advice on this problem, also.

    Thank you for your assistance.
     
  2. FugacityMan

    FugacityMan Thread Starter

    Joined:
    Dec 26, 2005
    Messages:
    4
  3. Tadtheo

    Tadtheo

    Joined:
    Oct 6, 2007
    Messages:
    138
    How important is the data on the system? You could just re-format the HDD, and start fresh. Even if you manage to remove the virus/malware I doubt that you'll get that system back to running where it was.
    I don't know how successful this will be, but you could try typing "SFC /SCANNOW" into run. If you can get there.

    Good Luck. :/
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Similar Threads - taskbar cannot start
  1. ImWolf
    Replies:
    1
    Views:
    859
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1004449

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice