Not sure

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

wattamess

Thread Starter
Joined
Dec 2, 2001
Messages
8
I'm not really sure if this is a hardware problem, but here goes.

On My System Properties under Network Adapters there are
yellow exclamation warning signs on the the my Existing Ndis2
Driver actually there are two slots for the same drivers. Both have these warning signs. I tried to Update the driver but It doesn't work. It give me this message ...Device Status
NDIS.VXD
device loader for this device could not load the device driver(code2).. To fix the problemUpdate Driver., So I did that & still
Yellow Exclamationon these drivers.I tried using my Windows CD It also tells me that this is the best driver, but the method doesn't work. Is this fixable? Am I missing something? Do I need to buy a new one? Any information would really be very helpful .
Thank You
My E-Mail is [email protected]
 

ich

Joined
Aug 11, 1999
Messages
403
NDIS stands for Network Device Interface Specification. It's pretty complicated but, very basically, it's a "wrapper" that allows different NIC's to be accessed by a common API. If that's not confusing enough, go here for a more detailed description.
I usually only see this problem on W95 and W98(1st ed.) machines that are using SPX as a network protocol. MS implemented support for the Novell protocol very poorly (intentionally?) and this isn't extreemly uncommon. The best fix, I've found, is to pull all adapters and protocols and reload them. Verify what protocols are being used and only reapply what you need.
I recommend removing all protocols (Control Panel/Network - you might want to write down what settings are in place for TCP/IP,) then remove all network adapters in Device Manager. The NDIS Adapter usually only shows up if there's a problem with the driver, (I don't think I've ever seen a card show up as an NDIS Adapter and still work) the card is showing as NDIS Adapter instead of what it is supposed to be showing up as (ie: 3COM 3C90x, etc.) The OS likes to redetect the card as an NDIS adapter instead of whatever the card actually is when it is redetected - if that happens, there are several things to try:
  1. The best solution is to change the network card - it's the only solution that works every time. Any card that is different than the old one will force the OS to start from scratch and eleminate the possibility it will redetect it as an NDIS adapter. Admittedly, this is easy for me since we have stacks of cards at work, but it's a pain. We usually try these other options first.
  2. Force a driver update using the driver software from the manufacturer. Update the driver, specify "Have Disk" and either use the software provided with the card or drivers downloaded from the manufacturer's website.
  3. After removing all traces of the current Networking setup in Device Manager and Network Properties, shut down, remove the card from the PC, boot all the way back up, shut down again, reinstall the card, boot up and let it be detected. This is the least likely to work, but if you don't have a spare card lying around and are having problems with the adapter redetecting as an NDIS Adapter, it's an option that works about 65-75% of the time.
    [/list=1]
    Good Luck!

    edit: auto parse messed up the url that I had manually parsed.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top