1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

oblivion missing magcore.dll error

Discussion in 'Games' started by Hollow16, Aug 28, 2010.

Thread Status:
Not open for further replies.
Advertisement
  1. Hollow16

    Hollow16 Thread Starter

    Joined:
    Oct 28, 2009
    Messages:
    11
    ok so the other day i tried installing oblivion on my windows 7 computer, after it was installed i tried running it and i got this error message "this program can't start because magcore.dll is missing from your computer, try reinstalling the program." so i did, but after reinstalling oblivion twice it still didn't work. after that i tried downloading a new one and put it in C:/Windows/System32 and register it by starting run and entering "regsvr32 magcore.dll", but i get this error message saying that the magcore.dll file is not the right version for a 64 bit OS, i've downloaded and tried every version of magcore.dll i could find but i still had the same problem. i tried updating directx and running a register cleaner too, but that didn't help.

    i have played this before on my old xp computer which i don't have anymore and it worked perfectly, i tried playing it on my laptop that has windows 7 and exept for very low frame rates it works.

    i've tried everything i can think of, any help would be great :).
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Similar Threads
  1. Ripzz
    Replies:
    1
    Views:
    704
  2. Techsupported
    Replies:
    9
    Views:
    7,387
  3. Beef246
    Replies:
    1
    Views:
    6,946
  4. rajien2
    Replies:
    6
    Views:
    4,521
  5. The Infinity
    Replies:
    3
    Views:
    8,044
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/946341