1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

OLYMPUS SP500UZ Format card error

Discussion in 'Digital Photography & Imaging' started by Jawohl, Jan 19, 2011.

Thread Status:
Not open for further replies.
Advertisement
  1. Jawohl

    Jawohl Thread Starter

    Joined:
    Feb 27, 2010
    Messages:
    7
    Hello, newbie here. Just acquired a used Olympus SP500UZ 6MP camera. Been using it for a week or two without a card, fine.

    Just got A) a brand new Olympus XD card 64MB, and then B) a brand new Fuji 64MB XD card. Neither will work in this camera.
    Starts off with the "format/power off" message. But "format" gives a half second of formatting then stops (every time!) with CARD ERROR!
    Tried cleaning the contacts in the slot with IPA, no difference.
    There seems to be a lot of this problem about with this camera, and maybe others. My question is, is there a definitive solution to it? Seems a bit useless--never had the problem with my old Smartmedia camera (C-700).

    Is there a surefire solution? Thanks
     
  2. Jawohl

    Jawohl Thread Starter

    Joined:
    Feb 27, 2010
    Messages:
    7
  3. DerekC

    DerekC

    Joined:
    Jan 10, 2005
    Messages:
    1,705
    If you have tried 2 brand new cards from different manufacturers, then I'm sorry to say, but it sounds like the camera may be defective. I suppose that you can try to format the cards in the computer first (if you have a XD card reader), then try to format them again in the camera.
     
  4. Jawohl

    Jawohl Thread Starter

    Joined:
    Feb 27, 2010
    Messages:
    7
    Thanks Derek, yes that may be possible. Seems to be a common problem with Olympus and XD cards though...that's an awful lot of faulty cameras. A common idea (it seems) is go to a shop who sell Fuji, have them format it in a Fuji, and it will then work in your Olympus(!).

    Gahh, must be a cleverer, less ridiculous solution to it somewhere. Reticent to buy a reader until I can be sure it'll work, but I might have to resort to that. Thanks anyway.
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/975699

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice