OneDrive giving me fits

This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.


Thread Starter
Jun 8, 2017
Tech Support Guy System Info Utility version
OS Version: Microsoft Windows 10 Pro, 64 bit
Processor: Pentium(R) Dual-Core CPU E6600 @ 3.06GHz, Intel64 Family 6 Model 23 Stepping 10
Processor Count: 2
RAM: 3991 Mb
Graphics Card: Intel(R) Q45/Q43 Express Chipset (Microsoft Corporation - WDDM 1.1)
Hard Drives: C: 232 GB (138 GB Free); E: 465 GB (330 GB Free); F: 931 GB (583 GB Free);
Motherboard: Hewlett-Packard, 3048h
Antivirus: Microsoft Security Essentials, Enabled and Updated

Hello again:

I don't mean to hog the forum but I have one more issue which has me at wit's end. I recently purchased OneDrive because I need to back up all that music I mention in the thread below among other things. So anyway, when I first started using it, it seemed to function seamlessly... until I noticed that the default setting was to sync to C: - which is inexplicable. I mean, if you are paying for 1TB of cloud storage and your system drive only has 500GB total, well over half of which is full, why would you sync twice that size data to C:? Anyway, no one here is expected answer for Microsoft's quirks but I panicked because I could figure out how to stop the sync and I was fast approaching "critical mass" on C:. So I gave remote access to a tech from Microsoft's OneDrive department and told him to just delete the music cache folder after unticking the sync to C: option (which I had been unable to find). This solved the problem, or so I thought. However, ever since, OneDrive will only hold about 35GB of data. No matter what I do. I deleted and reinstalled it to no avail. I deleted and cancelled Office 365 altogether and bought Office 365 for business (since I actually use it for my home business anyway) and installed the business editions of the software. No improvement. I spent EIGHT HOURS on the phone with them yesterday and nobody made any real attempt even to fix the problem - just kept generating tech support ticket numbers. Does anyone know how to solve this? I really am at wit's end here.
Apr 10, 2006
Think about this as an option....

Purchase an inexpensive hard disk, such as a Western Digital 1TB Passport HDD which retails for under US$100. Copy all the files that you want to keep onto that disk and then disconnect it from the computer.

Now follow the instructions below that I have simply C&P from Microsoft Support. Read Step 5 carefully before you start so that you understand what this process actually does.


Copied from Microsoft Support.... please note that I have not personally tested this but the procedure looks OK.

Hide OneDrive in Windows 10

OneDrive is built in to Windows 10, so it can't be uninstalled. But you can hide it and stop the sync process, so it stays hidden. To do this, turn off all the OneDrive settings and remove the OneDrive folder from File Explorer.

  1. In the Notifications area on the bottom of the Windows screen, right-click the OneDrive icon. You might have to click the Show Hidden Icons arrow to find OneDrive.

  2. Click Settings, and on the Settings tab, uncheck all the boxes under General.

  3. On the Auto save tab, set the Documents and Pictures lists to This PC only, and uncheck the other boxes.

  4. On the Account tab, click Choose folders.

  5. In the Sync your OneDrive files to this PC box, check and uncheck the box at Sync all files and folders in my OneDrive. (The first check selects all the boxes, then the uncheck clears them all.) Click OK to close the box and return to settings.

    This step removes all OneDrive files from your computer, but leaves them on

  6. Click OK to save your changes in the Settings box.

  7. Open the Settings box again: In the Notifications area, right-click the OneDrive icon, click Settings. On the Account tab, click Unlink OneDrive. Close the Welcome to OneDrive box that appears.

  8. Open File Explorer, right-click OneDrive, and then click Properties.

    On the General tab, next to Attributes, check the Hidden box. This hides OneDrive from File Explorer.

  9. One more time, back in the Notifications area, right-click the OneDrive icon and click Exit. This removes the OneDrive icon from the Notifications area.
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online