Online videos do not load or take a very long time to load

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

thadlozen

Thread Starter
Joined
Jun 1, 2011
Messages
5
I am trying to solve this problem on a friend's laptop. It is a Sony Vaio with Windows 7 64bit, using Chrome. Bought within the last year. I can play videos from sites like youtube, hulu, and sports sites, but when I try to play a video from putlocker, gorillavid, or other streaming sites typically used for videos like anime or tv shows the video either doesn't load (just spins) or takes a REALLY long time to load, almost like it is downloading the full video before it plays.

I borrowed another laptop from the library which also has Windows 7 and Chrome and all the videos play fine on it using the same internet connection, so it is definitely something local to this machine.

I have searched the net for three days trying to find a solution, but to no avail. I have the latest versions of flash, java, etc. I have tried older versions of flash. I've disabled the antivirus and firewall. Disabled the built-in flash plugin for chrome. I really am not sure what else to do. If anyone has any suggestions I would readily welcome them. I have tried other browsers as well and had similar issues.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top