Outlook 2007 working very slow.

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

wellington2010

Thread Starter
Joined
Aug 19, 2009
Messages
1
Outlook takes a long time to load, delete emails, etc. I send a daily devo to about 250 recipients. When I click send it does but it remains in the outbox as unsent, and there is no record of it in the sent items. However, individual messages go fine. I use Windows 7 professional and office enterprise. It used to work fine and then I had a trojan and it hasn't worked since. I got rid of the infection using PC Tools and IOBit 360 Pro.

Second problem: My computer no longer recognizes the format on my USB storage sticks. I am asked to format the drive and when I do it does not format. I've tried it with a new stick and got the same message. I haven't gone nuts yet but I seem to be on my way. Please HELP!!!:eek:
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top