Packard Bell Ixtreme 3720 Failure

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

mpstevens

Thread Starter
Joined
Mar 18, 2010
Messages
7
I have a .Packard Bell Ixtreme 3720 which will not boot. I have tried another PSU and disconnected all external peripherals and devices etc
The only power i can get is when i disconnect the 4pin cable from the PSU and only have the 20pin connecter which will cause the fan to start but no beeps or start up? As soon as i plug the 4pin connector back in i get nothing?
Any advise appreciated?
Regards
Mike
 

Oddba11

Jim
It's My Birthday!
Joined
May 12, 2011
Messages
8,336
Remove/disconnect everything leaving only the cpu installed and the power supply connected. So you will have a bare motherboard w/cpu and the power supply. Power it up and see what happens. You should get BEEP/ERROR codes for missing RAM. If not, it is one of those three components.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Top