1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved Paging file/ virtual memory keeps resetting

Discussion in 'Windows 7' started by piddles2009, Jan 12, 2017.

Thread Status:
Not open for further replies.
Advertisement
  1. piddles2009

    piddles2009 Thread Starter

    Joined:
    Jan 12, 2017
    Messages:
    7
    Hi! Every time i restart my pc a window pops up prompting me to set a paging file size because there is no paging file. Every time i put in the info i would like it tells me to restart my pc for the changes to take effect, even after the restart my pc will be reset to not having a paging file and ill be prompted once more. These are my cpu's specs. Thanks!
    Tech Support Guy System Info Utility version 1.0.0.4
    OS Version: Microsoft Windows 7 Home Premium, Service Pack 1, 64 bit
    Processor: Intel(R) Core(TM) i5-4460 CPU @ 3.20GHz, Intel64 Family 6 Model 60 Stepping 3
    Processor Count: 4
    RAM: 8053 Mb
    Graphics Card: NVIDIA GeForce GTX 970, -1 Mb
    Hard Drives: C: 931 GB (85 GB Free);
    Motherboard: Gigabyte Technology Co., Ltd., Z97-HD3
    Antivirus: None
     
  2. flavallee

    flavallee Trusted Advisor

    Joined:
    May 12, 2002
    Messages:
    78,505
    First Name:
    Frank
    Virtual memory for Windows 7 should be set on "System managed size".

    Capture.JPG

    ---------------------------------------------------------------

    That 1 TB(931 GB actual capacity) hard drive is over 90% full, so I'm guessing your computer is loaded with personal data.

    Why is there no full-time antivirus program installed?

    ---------------------------------------------------------------
     
  3. piddles2009

    piddles2009 Thread Starter

    Joined:
    Jan 12, 2017
    Messages:
    7
    I guess i forgot to pick up an anti virus program, ill get that today. I tried setting the paging file to "System managed size" at first but every time i restart my pc so that the change can take effect it will reset back to "No paging file"
     
  4. flavallee

    flavallee Trusted Advisor

    Joined:
    May 12, 2002
    Messages:
    78,505
    First Name:
    Frank
    After you select "System managed size", you need to click the "Set" button.

    --------------------------------------------------------------
     
  5. piddles2009

    piddles2009 Thread Starter

    Joined:
    Jan 12, 2017
    Messages:
    7
    upload_2017-1-12_8-2-10.png
    Okay i just did that, im going to restart my pc now, ill let you know if the performance options menu pops up again
     
  6. piddles2009

    piddles2009 Thread Starter

    Joined:
    Jan 12, 2017
    Messages:
    7
    After the restart the menu popped up again with "no paging file" selected.
     
  7. flavallee

    flavallee Trusted Advisor

    Joined:
    May 12, 2002
    Messages:
    78,505
    First Name:
    Frank
    You need to click the "Change" button so you can bring up the third window in my image.

    --------------------------------------------------------------
     
  8. piddles2009

    piddles2009 Thread Starter

    Joined:
    Jan 12, 2017
    Messages:
    7
    I did that, after selecting change i checked "system managed size", then "set", then "ok". After that it told me that another file exists with the same file name and if i wished to overwrite the existing file with a page file. I selected yes. Afterwards it told me the changes i made require me to restart my computer before they can take effect. Directly after that i restarted my cpu and when my cpu started up again the same "performance options" menu popped up. I went to "change" to make sure that my changes saved but the "no paging file" was selected once more.
     
  9. flavallee

    flavallee Trusted Advisor

    Joined:
    May 12, 2002
    Messages:
    78,505
    First Name:
    Frank
    I have several computers running Windows 7 and have never had a problem with keeping the "System managed size" setting, so I don't know what you're doing wrong.
    If you have a computer-knowledgeable family member or friend, ask that person to help you.
    I suspect there's something else wrong with your computer that I'm not aware of.

    ---------------------------------------------------------------
     
  10. piddles2009

    piddles2009 Thread Starter

    Joined:
    Jan 12, 2017
    Messages:
    7
    There might be something else wrong, ive spent some time googling it and i see that others with windows 7 have the same problem sometimes, ive tried going into the command prompt as an administrator and running an sfc scan. After the scan it says that there are problems with my pc that could not be repaired during the process
     
  11. flavallee

    flavallee Trusted Advisor

    Joined:
    May 12, 2002
    Messages:
    78,505
    First Name:
    Frank
    If a Windows 7 "repair" isn't successful, a Windows 7 reinstall and fresh start is usually the best option.

    ---------------------------------------------------------------
     
  12. piddles2009

    piddles2009 Thread Starter

    Joined:
    Jan 12, 2017
    Messages:
    7
    I fixed it after searching google for a bit longer!!!!! ill post the solution here.
    My fix:

    Go to Control Panel and click the "Appearance and Personalization" link.

    Click "Show hidden files and folders", under the FOLDER OPTIONS link.

    Under "Hidden Files and Folders", click the bullet, "show hidden files, folders, and drives".

    Also, uncheck the box, "Hide protected operating system files(Recommended)".

    Apply changes if need be.



    Now click start button, then Computer. Click on C: drive, and you should see a pagefile.sys . DELETE IT. Go back to where you can set your paging file. Click system managed file size, set, and automatically have windows manage it. OR set a custom amount and apply changes.

    This time, it will not ask you to override the existing pagefile.sys

    Restart your computer. Upon restart a new pagefile should have been created. You may get a message telling you so, and the pagefile settings that you designated should finally be set and saved. If not, set the pagefile now, making sure to set and apply, then restart computer again.



    I didn't have to restart twice, but mistakes can happen. For those that couldn't get this fixed with the sc config command prompt, I hope this helps. Also, may want to go back to hidden files and folders to hide the OS files(recommended) if you're leery about accidentally messing something up in the future.
     
  13. flavallee

    flavallee Trusted Advisor

    Joined:
    May 12, 2002
    Messages:
    78,505
    First Name:
    Frank
    This is one of the first setting changes that I make after setting up a Windows 7 computer for the first time.
    Capture.JPG

    -------------------------------------------------------------

    Anyway, I'm glad to hear you got it resolved. (y)

    -------------------------------------------------------------
     
  14. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1183751

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice