1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Paintshop Pro 9 won't run

Discussion in 'Digital Photography & Imaging' started by ralamb, Apr 3, 2012.

Thread Status:
Not open for further replies.
Advertisement
  1. ralamb

    ralamb Thread Starter

    Joined:
    Apr 3, 2012
    Messages:
    2
    I can not get Paintshop Pro ver 9 to run on my Windows Vista desktop. It was working fine and now without doing anything out of the ordinary it won't load. I have uninstalled it several times and reinstalled it. I am not running Norton 360 which I read was a problem but I am running Norton Internet Security Online. I took someones advice and ran a better uninstall program called Revo Uninstaller which did indeed delete 1311 addl entries in the Registry having to do with Paintshop Pro and reinstalled it but it still won't run. It is in memory as I see it in the Task Maanger list of programs running but it won't appear on the screen. I am stumped as to how to get it work AGAIN. Any ideas
     
  2. pip22

    pip22

    Joined:
    Nov 21, 2004
    Messages:
    2,536
    PSP 9 is not actually compatible with Windows Vista - I can't explain why it used to run okay but won't now.
    The earliest version that's compatible with Windows Vista is PSP X (ie PSP v10).
     
  3. ralamb

    ralamb Thread Starter

    Joined:
    Apr 3, 2012
    Messages:
    2
    Dear pip22.
    I bought a later version of Paintshop Pro X2 but it was so slow in loading files I gave up on it and reverted back to ver 9. Now 9 won't work on this machine which it did before for months and months, so now I installed version 8 which I have. Version 8 is working now, but who knows for how long. Have you used versions later than X2. I am wondering if they corrected the slow load problem. I am so disappointed that ver 9 won't work. Richard lamb. Thanks for you response to request.
     
  4. fairnooks

    fairnooks Banned

    Joined:
    Oct 1, 2007
    Messages:
    5,251
    I have them all (always get sucked in with a great upgrade price) and none of them are particularly slow to load; just isolated instances; for example sometimes it would take a long time to load the font library cuz I had installed 300 additional fonts. Of any though, maybe 10 is the fastest to load for me...and I think you should still be able to use old versions easily in Win7. Like I said, I have them all going back to version 7 (trial of 6) and that works on 7.
     
  5. jakey8

    jakey8 Banned

    Joined:
    Aug 18, 2009
    Messages:
    344
    You could try running PSP9 in Compatiability mode and set it to Windows XP SP3. It depends on what version it's intended to run on, whether Windows 2000, Windows 98/ME.
     
  6. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1047864

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice