1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Password now required to access workgroup computer...

Discussion in 'Networking' started by johnducker, May 28, 2007.

Thread Status:
Not open for further replies.
Advertisement
  1. johnducker

    johnducker Thread Starter

    Joined:
    Jan 22, 2000
    Messages:
    18
    Hi,
    I have a two computer network set-up consisting of one WinXP Home and one WinXP Pro, both on SP2. Recently, SyncToy stopped working on the XP Home machine - it said that the target server was not available. The shares could be seen in 'My Network Places'. Clicking on one of these shares prompted me for a password for a username of 'Guest'. I took a guess at this based on passwords I commonly use and eventually found it. SynToy started to workagain. I have to do this now for each session.

    What has changed and how can I put it back as it was, with no password?

    Thanks for your time,
    John.
     
  2. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,409
    Give this a try. :)

    Create a file in notepad named FIXANON.REG with the following contents:

    ------------------- Use text after this line -------------------
    Windows Registry Editor Version 5.00
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa]
    "restrictanonymous"=dword:00000000
    ------------------- Use text before this line -----------------

    Double click on the file and say Yes to the merge into registry question.
     
  3. johnducker

    johnducker Thread Starter

    Joined:
    Jan 22, 2000
    Messages:
    18
    Well, that works but it doesn't survive a reboot - is there a way to make it permanent?

    Many thanks,
    John.
     
  4. TerryNet

    TerryNet Terry Moderator

    Joined:
    Mar 23, 2005
    Messages:
    69,547
    "... is there a way to make it permanent?"

    Find what's changing it. Some kind of Internet Security suite (firewall) maybe?

    Does it survive a boot into SAFE mode?
     
  5. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,409
    The fact that it works indicates that Terry is correct, some security software is preventing permanent changes to the registry.
     
  6. johnducker

    johnducker Thread Starter

    Joined:
    Jan 22, 2000
    Messages:
    18
    Rats!
    now it doesn't work at all. I have used regedit to confirm that the update has survived a reboot. All I can think is that I must have typed the password at some point before running the registry update which made me think that the fix had worked when it hadn't. Sorry for misleading you.

    John.
     
  7. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,409
    You can create a user account on the "server" with the same name/password as is used to login to the client machine. That will also eliminate the password prompt.
     
  8. johnducker

    johnducker Thread Starter

    Joined:
    Jan 22, 2000
    Messages:
    18
    Thanks,
    that works. Would it also work to remove the password from the 'guest' account? If so, how?
    John.
     
  9. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,409
    Control Panel, User Accounts, Guest. You can modify the account there. However, I don't see any option to password protect the Guest account, never tried.
     
  10. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/578131