PC booting but not displaying

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Samweb132

Thread Starter
Joined
Jul 11, 2019
Messages
1
My PC seems to booting up and the fans and rgb are working but it's not displaying on the monitor when I plug it in. Does anyone know why or a possible fix?
 

managed

Allan
Trusted Advisor
Spam Fighter
Joined
May 24, 2003
Messages
13,958
Hi and welcome to TSG.

When you say 'when I plug it in' what plug are you referring to ?
 
Joined
May 18, 2004
Messages
337
It could be a number of things. The monitor itself, the cable you are using, the power supply, the video card, etc.

I would begin by eliminating potential causes.

  • Try a different cable and/or a different input (ex: HDMI instead of Display Port, etc)
  • Try the same machine on a different monitor
If the above doesn't work, it could be that the video card is dead or that the power supply isn't giving the machine enough power to fully boot.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Top