PC crashed & now I'm having a boot issue

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

TowerRed

Thread Starter
Joined
May 29, 2019
Messages
2
Hello,
I've had an issue for awhile where my games would minimize or crash by themselves; Recently I went to play a game then noticed green & purple dots appear on the screen followed by the game freezing. I reboot the computer & was supprised to find no OS found so I figure that the M.2 drive got fried being under the graphics card.

The next day I bought a new M.2 drive & re-installed Windows onto it; It worked fine aside from being slow & looking like a "safe mode" version of windows.. So I allowed it to do it's updates which downloaded correctly, restart for the updates to finish installing. The updates seemed to be installing fine during the boot but right after I was met with both monitor not having a signal. I repeated this process a couple more times & the last time I let it do it's thing for 8 hours with no change.

-Aorus X470 Ultra Gaming Motherboard
- Ryzen 5 2600x 6 Core
- 26G Of gaming ram
- Gigabyte RTX 2070 GPU
- 500GB WD Black M.2
- 1.5TB Triditional HD
- 6 Case Fans (3 intake, 3 exhaust)
- 800W Power Supply
 
Last edited:
Joined
Apr 20, 2019
Messages
118
Actually, a simple explanation and a fix is that it isn't your m.2 drive. It is your RTX 2070 which is overheating or probably dying. You should have brought a new GPU to fix that. Or even maybe your drivers are not good.
 

TowerRed

Thread Starter
Joined
May 29, 2019
Messages
2
Actually, a simple explanation and a fix is that it isn't your m.2 drive. It is your RTX 2070 which is overheating or probably dying. You should have brought a new GPU to fix that. Or even maybe your drivers are not good.
The GPU would make sense, I didn't even consider it since I've had it for less then a year; The display was lost when I tried to update my GPU driver so it must be that.

Thanks for the help
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top