pc has been off for months, no now picture

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Paintedeyes

Thread Starter
Joined
Dec 3, 2006
Messages
107
so i got a laptop a few months ago and i've bee using that at college instead of my pc. I turned of my pc so it wouldn't just be running for a while for no reason. i turned it on a week or 2 ago and there is just no picture. ive narrowed it down to my video card which is 2 years od, 7800 gt. i used that little digital to analog converter thing but i used the same one and plugged it into my laptop and works great. i've taken the video card out, cleaned the dust out, cleaned the inside of my computer. what should i do?
 
Joined
Mar 18, 2008
Messages
458
No picture even after removing and reinserting the card? Try a new video card.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top