PC on, no display after new CPU

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Sethieboy1

Thread Starter
Joined
Nov 6, 2020
Messages
3
Today I upgraded my CPU from ryzen 3 1200 to a 5 3600, I followed the instructions and I installed the CPU + Stock wraith fan properly. When I turn on the computer, all the fans start running and the red LED on the motherboard lights up. Only there is no display. Its plugged into my 1050ti,and I didnt touch or move anything since it last worked. Im out of options, whats wrong? 16046916804755111869335687737209.jpg16046916964457153363549725754925.jpgPlease help!
 
Joined
Apr 2, 2002
Messages
3,491
Perhaps the motherboard needed a BIOS update before running with the newer 3600.
You can always put the original CPU back in and do the upgrade, then switch.
 

crjdriver

Moderator
Joined
Jan 2, 2001
Messages
44,202
The only motherboards that have native support ie [without a bios update] for a 3xxx processor are the X570 and B550 chipset motherboard AND neither of those will support a 1xxx processor. Post the exact motherboard you are using and we can check to see IF it supports the processor you installed.

Note just because a motherboard has a given socket ie AM4, 1151, whatever does NOT mean it supports all processors based on said socket. You must check the support page for the motherboard to see IF the cpu you want to install is supported.
 

flavallee

Frank
Trusted Advisor
Joined
May 12, 2002
Messages
83,861
Post the exact motherboard you are using and we can check to see IF it supports the processor you installed.
Which motherboard do you have?
Since you haven't yet provided that information, I'll be the third person to ask you.

What is the brand name and exact model number of the motherboard?

-------------------------------------------------
 

Sethieboy1

Thread Starter
Joined
Nov 6, 2020
Messages
3
Since you haven't yet provided that information, I'll be the third person to ask you.

What is the brand name and exact model number of the motherboard?

-------------------------------------------------
MSI X370 GAMING PLUS
AMI 5.40 currently installed
 

flavallee

Frank
Trusted Advisor
Joined
May 12, 2002
Messages
83,861
MSI X370 GAMING PLUS (support site)

According to its specs, it has an AMD X370 chipset.

Be patient and wait for crjdriver to reply back.

-------------------------------------------------
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top