PC Will Not Power Up

Nikolarumy20

Thread Starter
Joined
Jan 14, 2022
Messages
3
So,my pc just shuted down and i couldn`t start him.I bought a new power supply,but has the same problem,so i tryed step by step and found out that my pc is starting up fine only if i dont plug in the CPU 8pin cable to the motherboard.If that cable is pluged in,it wont start...Anyone know what is the issue there?
 

cwwozniak

Chuck
Moderator
Joined
Nov 28, 2005
Messages
72,010
Hello, Nikolarumy20, and welcome to TSG.

It sounds like you have a hardware-related problem and you have not given us any details about your particular hardware.
  • If the computer is an unmodified product from a major manufacturer, please tell us the name of the manufacturer and the full and exact model number of the computer. In the case of a Dell brand computer, also please tell us the service tag number that should be on a label attached to the outside of the computer.

  • If the computer is a modified product from a major manufacturer, please tell us the information requested above and tell us what the modifications are, including the manufacturers and model numbers of any added or removed hardware.

  • If the computer is custom-built, please provide a parts list of all the major components used in the build, including the names of the manufacturers and the model numbers.
Also, tell us the brands and exact model numbers of the old and new PSUs.

Does anything happen when you press the power switch on the computer when you try to turn it on?

EDIT:
CPU 8pin cable to the motherboard
What kind of cable is this and what connector does it connect to on the motherboard?
 

Nikolarumy20

Thread Starter
Joined
Jan 14, 2022
Messages
3
My PC was build by a friend of mine,but he lives in another city and im also covid 19 positive,so he cant come and have a look.The 8pin CPU cable,is the cable that ussualy is on the left side on the motherboard,and goes from power supply.Long story short,if i press the power switch qnd that cable is plug in i just see a flash and nothing happens.If that cable is not pluged in pc starts but i dont have an image​
 

cwwozniak

Chuck
Moderator
Joined
Nov 28, 2005
Messages
72,010
It sounds like something is shorting or overloading the CPU power feed. It could be a failed CPU or possibly an insulator between the motherboard the case was not installed correctly or had shifted.

You could treat this as a problem build and use the problem build troubleshooting guide stickie post to check a few things out and isolate the cause.
https://forums.techguy.org/threads/troubleshooting-guide-for-problem-builds.580000/
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top