Pci Parallel Card Problem

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

retired96

Thread Starter
Joined
Dec 30, 2005
Messages
13
I have a new Dell Desktop with only USB ports. I have a 4 year old OKIPAGE 6W which is a parallel port printer. I installed a PCI Parallel Card and that's as far as I could get. The computer recognizes something is in the Parallel Port but, what it is is a question mark in device manager. I tried 80 different ways to install the drivers. I used the install disk I originally got. I installed the updated drivers from the oki site. The printer's icon is in the PRINTERS AND FAXES window. The new drivers are in the computer. I followed the Add Hardware Wizard. The printer will not print. "Drivers for this device are not installed. (code 28)." Was the only error message I received. Any suggestions?

George
 

JohnWill

Retired Moderator
Joined
Oct 19, 2002
Messages
106,726
You need to install the drivers for the parallel port card, they're different from the printer drivers.
 

retired96

Thread Starter
Joined
Dec 30, 2005
Messages
13
Installed drivers (thank you) but, I keep getting this message, "The parallel port driver has not been installed. Run the Printer Driver setup.exe on the setup disk to install it." I have installed the parallel port drivers and the updated driver for the Okipage 6W printer. The device manager shows a parallel port. The printer now prints one line of a document and the rest is blank. The printer worked 2 weeks before I fried my previous computer. I now run XP Home Media Center on my desktop.
 

JohnWill

Retired Moderator
Joined
Oct 19, 2002
Messages
106,726
Well, since the parallel port driver claims not to be installed, I think I'd work on that problem first. Does Device Manager show an error-free parallel port?

I'd uninstall all the parallel ports shown in Device Manager, uninstall the parallel port drivers from Add/Remove Programs if they appear, reboot, and install the drivers again.

Does the installation expect you to install the drivers before you install the board or after?
 

retired96

Thread Starter
Joined
Dec 30, 2005
Messages
13
Device manager shows an error free port. I spent two hours with a Dell tech who worked on my computer remotely. He tried everything and came to the conclusion that the parallel card does not support my printer. He said that the printer drivers are installed "half way," The printer prints 1/2 of the top line of each page of any document I try to print. The device manager shows the Parellel Port LPT 1 installed. The device manager does not show the existence of a printer. Yet the printer prints the top line of each document.

The tech did not uninstall the PCI cards drivers but, he did reinstall them over the original one that I installed. He went through the ADD Hardware Wizard many times, in many different ways.

What to do?
 

retired96

Thread Starter
Joined
Dec 30, 2005
Messages
13
The parallel card instructions say to install the drivers AFTER the card is plugged in. Does that change anything if you install the software BEFORE the card is plugged in?
 

JohnWill

Retired Moderator
Joined
Oct 19, 2002
Messages
106,726
I'd follow the instructions. Some devices want to have the drivers loaded first, I just wanted to make sure of what you had. Did you check to see if there are any updated drivers on the manufacturer's website?
 

retired96

Thread Starter
Joined
Dec 30, 2005
Messages
13
I downloaded the updated drivers for the printer. I did not look for updated drivers for the card. I will do that but, the card does support XP.
 

retired96

Thread Starter
Joined
Dec 30, 2005
Messages
13
Thanks for all your help but, it didn't work. I uninstalled the PCI cards drivers. I searched for updated drivers on the website. I'm not sure that there was a later one but, I can call tomorrow and see. I reinstalled the drivers of the PCI and rebooted. I reinstalled the updated drivers for the printer. I rebooted and got the same "The parallel port driver has not been installed. Run the Printer Driver setup.exe on the setup disk to install it."

Thanks again for your help. It looks like my Okipage 6W is to become a door stop.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

No members online now.
Top