1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Peculiar issue with sata hard drive when changed from internal to usb enclosure

Discussion in 'Hardware' started by tranquillian, Apr 8, 2010.

Thread Status:
Not open for further replies.
  1. tranquillian

    tranquillian Thread Starter

    Joined:
    Apr 8, 2010
    Messages:
    2
    I've had hard drive issues before and been able to solve them via device manager and disk management etc, but this one has me stumped, I'd very much appreciate some ideas!
    A bit of relevant background - I have a HTPC running Windows 7 with two 2TB Western Digital Green Power HDD's connected by sata. They both work fine, and I've had no trouble with either.
    Today I bought a dual sata USB hard drive enclosure to put them both in, as I'd like to take my film collection with me hooked up to my laptop every now and then.

    I installed them both in the enclosure, plugged the usb lead into my laptop, and waited for the usual recognition sounds and autoplay pop-ups etc.
    However when I went to My Computer, only one was showing, my drive named "films 2".
    The LED on the enclosure to show activity was only lit on the left side, which meant it wasn't picking up both drives. I went into disk management and device manager, and the "hidden" drive was nowhere to be seen.

    I double checked the connections on the enclosure, and powered down and up again, and distinctly heard both drives spin up, one immediately after the other.
    I then connected the enclosure to my HTPC, only for the same thing to happen.

    Next I plugged in JUST my "films 1" drive into the enclosure, and it did spin up but no glimmer of recognition in Windows, device manager or disk management! Whereas when I plug in just "films 2", it is recognised fine.
    I also tried swapping the sata connectors, ie. so that "films 1" was connected to the same connectors that I'd just had "films 2" running successfully on, in case the others were faulty. Still no luck.

    At this point I was worried "films 1" had suddenly committed suicide of some sort, so I've gone and connected it internally again in my HTPC, and voila, relief, it appears as normal and is fully accessible...

    Both 2TB drives are identical, so I can't for the life of me figure out what's up with the troublesome one.
    They're both formatted the same, as NTFS Basic disks, with no errors, etc.

    Hope someone can help me out!
     
  2. Mumbodog

    Mumbodog

    Joined:
    Oct 3, 2007
    Messages:
    7,889
    Sounds like the enclosure may be bad, what model is it?

    .
     
  3. tranquillian

    tranquillian Thread Starter

    Joined:
    Apr 8, 2010
    Messages:
    2
    As of a few minutes ago I'm pretty sure you're right with that conclusion! It turns out I must have in my haste actually not tested each connection in the enclosure.
    I've just experimented with a 2.5 sata I had lying around - connecting it to sata1 + power = recognition, but connecting it to sata2 + same power = nothing at all. At this point I weakly hoped that the short sata cable in the enclosure was to blame, so I swapped it out for one of my own, but still the same result, so obviously a faulty item, damn it.
    So problem solved, I'll get it returned, sorry for posting without thoroughly checking! Cheers
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/915588

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice