Performance issues after updating AMD driver

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Ciiza

Thread Starter
Joined
May 31, 2019
Messages
1
Sorry for my english.

So, yesterday I updated my AMD graphic driver from version 19.1.1 to 19.4.1 and since then, I got issues with all of my games. (Apex Legends, Dota 2, Borderlands 2). Low FPS, black screen and long loading time.

In Apex legends after queuing for a match I got black screen and got disconnected from match into the main menu. I have to queue for a game about 3 times before it lets me into the game. But when it does my FPS are so low it's not playable.

In Dota after queuing match im sitting in black screen for about 20 seconds before game loads and I am able to pick my hero. It was instant before updating drivers. Went from 60 FPS to 30 FPS.

Borderlands loads fine but I went from stable 60 fps to 40 - 60.

First logical step I did was downgrading driver back to 19.1.1.
I used DDU in safe mode. But nothing changed, I still got the same issues.

In Radeon settings I tried to set power limit from 0 to +20.
Still same.

My HDD got plenty of space so it is not that.
My Windows is up to date.

I think something had to change in the driver and won't change back with downgrade, but I have no idea what it could be. Any help would be appreciated.

My specs: https://i.imgur.com/IUOgXBA.png

I know my PC is no good but I was still able to play those games with reasonable fps.

Radeon settings: https://i.imgur.com/zceCYPA.png https://i.imgur.com/rKLNw7K.png

Also I noticed in Device Manager there are 2 graphic adapters. Maybe it is related to the problem? https://i.imgur.com/vlxWbRX.png

Thank you very much.
 
Last edited by a moderator:

Cookiegal

Karen
Administrator
Malware Specialist Coordinator
Joined
Aug 27, 2003
Messages
117,957
I've edited your post for language. Please be more careful in the future as this is a family friendly site.
 

Oddba11

Jim
Joined
May 12, 2011
Messages
8,179
Where was the update from?

Try manually installing the newest version provided by Lenovo.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top