1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

"Permissions" problem with USB drive, after fixing viruses

Discussion in 'Windows XP' started by dlarryhancock, Jan 16, 2008.

Thread Status:
Not open for further replies.
Advertisement
  1. dlarryhancock

    dlarryhancock Thread Starter

    Joined:
    Jan 16, 2008
    Messages:
    9
    Hello everyone.

    I hope that someone may be able to help me with a difficulty I am having.

    As of four days ago, my Windows 2000 system was working fine, with no known problems. However, I foolishly went looking for some extra-wide wallpaper (to stretch over dual monitors) and ended up being virused. I was no longer able to access some of the websites I normally went to, and links to wallpapper sites and PartyPoker.com kept popping up.

    I had installed HiJackThis and had it do a scan, but I am not knowledgable enough to use it effectively. I did NOT notice anything unusual in the scan log though.

    After a bunch of looking around, I eventually ran PCTool's sdstart.exe and then SmitfraudFix.cmd.

    This seems to have solved that problem.

    However, another problem has arisen as a result.

    In addition to my internal hard drive, I have attached a large USB external hard drive. This drive is my "F" drive.

    I do a lot of downloading from newsgroups and all of that information is downloaded to my F drive.

    However, suddenly all access to the F drive has slowed to a crawl, and all files are "saving" with a 0 size.

    Doing a little more detective work... when I have IE 6 open and try to save a file or image to the F drive, I get a warning dialogue box that says:

    "This file is on a network drive with create but no modify privileges. Ask the administrator of this network to change this condition."

    If I try to do the same Save As to my internal hard drive, there is no difficulty with the Save and no error message.

    So my problem appears to be with Permissions for the USB drive.

    When I go to My Computer, the right click on my F drive, the only place I see anything about permissions is in the Sharing tab.

    My F drive is assigned the share name of $F
    The comment reads Default share
    User limit: Maximum allowed
    If I click on "Permissions" I get a "Sharing" warning saying "This has been shared for administrative purposes. Te permissions cannot be set"

    Other information that may hep...

    When I boot up my Windows 2000, I log in as Administrator with NO password.

    If I open two Windows Explorer windows and drag a file from the internal C drive to the F drive, I can successfully copy the file to the F drive. However, if I then try to delete that file, I get an error message saying "Cannot delete xxxx.xxx: there has been a sharing violation. The source or desitnation file may be in use".

    If I try to delete a file that was already on the F drive, it WILL delete that file, but it takes a long time to do so.


    So, my problem appears to be with Permissions for the F drive, specifically in regards to deleting files.

    Any suggestions?

    Thank you,
    Larry Hancock
     
  2. dlarryhancock

    dlarryhancock Thread Starter

    Joined:
    Jan 16, 2008
    Messages:
    9
    My query made it to the bottom of page 3 in 15 hours.

    Hopefully someone has a suggestion?

    Thanks,
    Larry Hancock
     
  3. TheOutcaste

    TheOutcaste

    Joined:
    Aug 7, 2007
    Messages:
    9,028
    I'm puzzled why Win2K would see a USB drive as a Network share. Very puzzled.
    The Admin share (F$) shouldn't have anything to do with it as it's a local drive, but you can try deleting that share -- it will recreate when you reboot. To delete it, right click My Computer, click Manage, then Expand Shared Folders and click Shares. Right click the F$ share and choose stop sharing.

    If it's formated NTFS there should be a security tab when you right click and choose properties. If the drive is formatted FAT/FAT32 there will be no Security tab.
    If it's an NTFS drive finding out why the security tab is missing will be step one.


    I would also remove the drive in Device Manager under disk drivers, and let it be re-detected on a reboot.

    You may want to consider removing all the USB entries and letting those re-install as well.


    You may want to start a NEW thread in the Malware Forum and post a HiJack This log and link back to this thread. This is the link to use:
    Code:
    http://forums.techguy.org/windows-nt-2000-xp/672428-permissions-problem-usb-drive-after.html#post5517204
    Go to Download HiJack This
    • Click the Download HijackThis Installer link.
    • Save HJTInstall.exe to your desktop.
    • Double click on the HJTInstall.exe icon on your desktop.
    • By default it will install to C:\Program Files\Trend Micro\HijackThis
    • Click Install
    • Click the I Accept button on the License Agreement Window
    • The Main Menu window will open
    • Click on the Do a system scan and save a log file button.
    • It will scan, save the log in C:\Program Files\Trend Micro\HijackThis, and then the log will open in Notepad.
    • In Notepad, click on Edit > Select All then click on Edit > Copy to copy the entire log.
    • Start a new thread in the Malware Removal Forum
    • DO NOT have HijackThis fix anything yet. Most of what it finds is required or harmless.
    Give as much information about the problem as you can.

    • OS version and Service Pack installed
    • Exact text of any error messages
    • Any new Software or Hardware installed
    • The link back to this thread, or copy and paste your first post in the new thread
    • Include whether the USB drive is formated NTFS or FAT/FAT32
    From the Rules

    Log Analysis/Malware Removal - In order to ensure that advice given to users is consistent and of the highest quality, those who wish to assist with security related matters must first graduate from one of the malware boot camp training universities or be approved by the administration as already being qualified. Those authorized to help with malware issues have a gold shield [​IMG] next to their name and authorized malware removal trainees have a blue shield [​IMG] next to their names. Anyone wishing to participate in a training program should contact a Moderator for more information.

    Be patient. The malware experts are very busy and will get to you. Older posts with zero replies will likely get responded to sooner, so don't bump your post or add information for at least 24 hours. You can edit your post during the first 24 hours if you need to add anything you forgot. To edit your post, click the EDIT button by the post you want to edit.
     
  4. dlarryhancock

    dlarryhancock Thread Starter

    Joined:
    Jan 16, 2008
    Messages:
    9
    Thank you for the reply.

    In regards to why the F drive is shared, I neglected to mention that I DO have a second computer, which is connected to the first through my cable company's home networking modem, and I DO wish to have access to my computer's F drive from the other computer, hence the network sharing.

    I tried uninstalling the USB drive (it is a FAT32 drive) and reinstalling it, but that has not helped.

    Also, the virus problem appears to have resurfaced. I HAVE shut down the other computer for the duration of solving this problem so that any infection that may be there has not migrated to the computer we are talking about. However, this evening when I get home I will hook up this computer's F drive (the one I am having difficulty in saving files to from IExplorer and other software) directly to the other computer and see if the problem occurs there as well.

    I will indeed post a thread to the Malware Removal Forum and see if they can help rid me of my virus problem.

    Thank you again for the reply.

    And, if anyone else has any suggestions on THIS problem, I am all ears!

    Larry Hancock
     
  5. TheOutcaste

    TheOutcaste

    Joined:
    Aug 7, 2007
    Messages:
    9,028
    Just a FYI on sharing, the <driveletter>$ share is present on all the drives. With the $ behind it, it will be hidden, meaning it can't be seen when browsing the network in My Network Places, you have to know it's there to connect to it. You can't change permissions on it. Members of the Administrators group on that PC will always have full control access.
    If you need to set permissions, say read only for the kids so they can't delete anything or fill up the drive, or want it available without having to enter a username/password, you can add another share and set permissions as needed.
    If the name you give it ends with a $, it too will not be visible when browsing the network.

    Good luck with the nasty bugs.

    Jerry
     
  6. dlarryhancock

    dlarryhancock Thread Starter

    Joined:
    Jan 16, 2008
    Messages:
    9
    I had not been aware of the significance of the $ - when I go into the drive properties and tell turn on the shared property, the $ is already there - so I have left it there. I will try removing it once things have calmed down, just to see what happens.

    Update...

    My problems so far with my F drive have been in relation to a 500 Gb Hard Drive which is plugged into one of the USB ports at the back of my computer.

    This evening plugged my 4 Gb flash drive/USB thumb drive.. whatever.. into onthe othe USB ports at the front of the computer.

    I have exactly the same difficulties trying to save to that drive.

    So I am suspecting that my problem may be due to the viruses I have not successfully removed yet, or to problems that remain behind even if I have successfully deleted them.

    As suggested I have posted a separate thread (referring back to this one) in the Malware and virus forum to try to get help on the virus end of things.

    However, if curing the virus does not solve my access problems, I still need to find out how to save from internet sources to my USB drives.

    Larry Hancock
     
  7. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/672428

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice