1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Permissions - XP Pro.

Discussion in 'Networking' started by Katzy, Apr 17, 2004.

Thread Status:
Not open for further replies.
Advertisement
  1. Katzy

    Katzy Thread Starter

    Joined:
    Nov 9, 2003
    Messages:
    563
    XP Pro.

    Since I had to blatt my HD and reinstall everything, something wierd has manifested itself.

    If I have to sort some of the minor hassles on Jane's machine, I can, usually, do it from mine, via the network (Notwork?).

    I have permissions set on the root of her drives, but I couldn't set permissions on her "C:\Program files" directory. All I got was this:

    [​IMG]

    With all the useful bits greyed-out. Deep joy.

    Before I had to go down the "Blatt" road, I had access to all of her little places (OO-ER!), so what on Earth has changed?

    I've disabled Simple File Sharing, to see if that helps, and, even though permissions are, now, set for "Everybody" to have full access, I'm getting this:

    [​IMG]

    Odd. I can get into "Documents and settings" and everywhere else, but not "Prog files", nor "Windoze".

    Both machines have full admin rights.

    Ho-hum

    I've had a search, but I've found nothing to explain this. Will someone, please, put me out of my misery?
     
  2. 10forcash

    10forcash

    Joined:
    Aug 7, 2003
    Messages:
    343
    The easiest way to do this is to switch to 'Classic' mode, this will then give you access to W2k style property pages
    Click on the 'new share' button and create a share on the root of the drive, then set permissions.
    Cheers,
    10forcash
     

    Attached Files:

  3. 10forcash

    10forcash

    Joined:
    Aug 7, 2003
    Messages:
    343
    As an afterthought, try mapping the default admin share \\janes\c$ as a network drive on your PC, enter a valid username and password and tick the 'reconnect at logon' box
    Cheers,
    10forcash
     
  4. Katzy

    Katzy Thread Starter

    Joined:
    Nov 9, 2003
    Messages:
    563
    That's odd. It says that the path can't be found, even though I browsed to it! Windoze, eh? :(
     
  5. Bob Cerelli

    Bob Cerelli

    Joined:
    Nov 2, 2002
    Messages:
    22,468
    I thought XP Pro with NTFS would not allow you to share those to directories.

    You might try playing with the Simple File Sharing setting in the Windows Explorer to see if that changes things.
     
  6. Katzy

    Katzy Thread Starter

    Joined:
    Nov 9, 2003
    Messages:
    563
    I tried that, Bob. As I said, in my original post, it DID alter thins from the first pic I put, to the second... :(
     
  7. 10forcash

    10forcash

    Joined:
    Aug 7, 2003
    Messages:
    343
    XP creates admin shares by default, the C$ share should always accessible using the administrator account / password combination. use the fully qualified computer name \\computer\c$, if it doesn't work, could be a problem with DNS, try using the IP address instead, eg. \\192.168.0.1\c$.
    I manage several networks, some XP only p2p, some mixed p2p and some Domain, the default share is always installed and windoze complains like mad if you try and delete it.
    Cheers,
    10forcash
     
  8. Bob Cerelli

    Bob Cerelli

    Joined:
    Nov 2, 2002
    Messages:
    22,468
    Turn off simple file sharing in the Explorer.
     
  9. Bob Cerelli

    Bob Cerelli

    Joined:
    Nov 2, 2002
    Messages:
    22,468
    Also, it is pretty simple to delete the admin shares. Just one registry edit.

    From an MS page"

    "To delete the hidden administrative shares for all root partitions and volumes (such as C$) and the system root folder (ADMIN$) and prevent Windows from re-creating them, add an AutoShareWks DWORD value to the following registry key and set its value data to 0:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters"

    http://support.microsoft.com/default.aspx?scid=kb;en-us;Q314984&sd=tech
     
  10. Katzy

    Katzy Thread Starter

    Joined:
    Nov 9, 2003
    Messages:
    563
    As I said, in my original post, the simple sharing thing is disabled. I did the regedit and it's had no effect.

    I also tried your suggestions, 10forcash. It almost worked on the IP address, but it insisted on being given a password, even though no password has ever been set on either machine. Nice to see another Englishman, here, though!

    This is getting weirder and weirder...
     
  11. Bob Cerelli

    Bob Cerelli

    Joined:
    Nov 2, 2002
    Messages:
    22,468
    What happens if you share the root of the C: drive but give it a different share name. Don't use the admin shares.
     
  12. Bob Cerelli

    Bob Cerelli

    Joined:
    Nov 2, 2002
    Messages:
    22,468
    I thought the default setting for XP Pro is to require a password for network access.

    To change this setting:

    Run gpedit.msc
    Go to Computer Configuration / Windows Settings / Security Settings / Local Policies / Security Options
    Double click on Accounts: Limit local account use of blank passwords to console login only
    Disable this option
     
  13. Katzy

    Katzy Thread Starter

    Joined:
    Nov 9, 2003
    Messages:
    563
    Still not accessible...

    If it wasn't for the fact that I can access the rest of Jane's machine, I'd be thinking "Firewall". It can't be that, though, can it? Not if I have access to other places...?

    Thanks fo efforts, though, guys!

    I'm stumped.
     
  14. Bob Cerelli

    Bob Cerelli

    Joined:
    Nov 2, 2002
    Messages:
    22,468
    So you did something like:

    1. Share the C: drive as "c_drive" - just as an example.

    2. Make a network connection to that share

    Do you get the same access denied error message when trying to connect to this share...but connecting to other shares works ok?

    Just as a test, have you tried creating a matching user account and password on both computers.
     
  15. Katzy

    Katzy Thread Starter

    Joined:
    Nov 9, 2003
    Messages:
    563
    When I first set up the network, I had access to Jane's C: drive and both partitions on her other one. Then, I made the mistake of installing Linux on my machine, on the same drive, though different partition. XP threw a fit and, to cut a logn story short, I had to blatt the Whole drive and do a virgin install of XP.

    As it happens, I've got Linux on the seperate drive, now. Pity I can't get a Linux driver for my modem, innit? :(

    Anyway, since I made the new XP installation, this problem has manifested itself. I set the shares up, as I'd done, before, but don't, now, have access to the directories I've mentioned. I DO, however, have access to every other file on every other partition and on her C: partition, too. I've tried deleting all shares and re-setting them up, to no avail. I have full admin rights, naturally.

    It's all rather surreal, innit?
     
  16. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/221182

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice