PERSONAL.XLSB does not open when existing excel files are opened in Excel 2010

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

nrheffley

Thread Starter
Joined
Nov 17, 2012
Messages
3
I am running Microsoft Office Professional Plus 2010 on Windows 7.

When I open Excel my personal.xlsb opens fine and my macros are available and I can create new macros. No problems.

BUT when I open any existing Excel file the pesronal.xlsb is not opened and therefore no macros and I cannot create new macros as I get the error "Personal Macro Workbook in the startup folder must stay open for recording." I have been trying things all night with no luck. Any suggestions would be greatly appreciated. I will list the things I have tried or checked with no success below:

  1. In Options>Advanced Tab>General Section....the box for "Ignore other applications that use DDE" is NOT checked.
  2. In Options>Trust Center>Trust Center Settings>Trusted Locations... I have C:\Users\Nick\AppData\Roaming\Microsoft\Excel\XLSTART listed which is where my personal.xlsb is located
  3. In Options>Trust Center>Trust Center Settings>Macro Settings ...Disable all macros with notification...selected and not selected neither way solves the issue.
  4. In Options>Add-Ins>Manage: Disabled Items ...There are no disabled items.
  5. I have deleted HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Excel in the registry editor
  6. I have deleted C:\Users\Nick\AppData\Roaming\Microsoft\Excel\XLSTART\PERSONAL.XLSB and then run excel to create a new personal file.
  7. I have renamed C:\Users\Nick\AppData\Roaming\Microsoft\Excel\XLSTART\PERSONAL.XLSB to PERSONAL.XLSA

Thank you in advance for any help or suggestions.

Nick
 

nrheffley

Thread Starter
Joined
Nov 17, 2012
Messages
3
Why do you want it in xlsa?
Thank you for your reply Garf13LD. I don't want it in xlsa that was just a suggestion that helped someone else with a similar issue that I tried. I just want my macros to be available when I open an existing excel file.
 

nrheffley

Thread Starter
Joined
Nov 17, 2012
Messages
3
Try putting it in excel startup or office startup.
Thank you Garf13LD. I copied my personal.xlsb from C:\Users\Nick\AppData\Roaming\Microsoft\Excel\XLSTART\PERSONAL.XLSB and pasted it into C:\Program Files (x86)\Microsoft Office\Office14\XLSTART and I now have my macros when I open an existing excel file.

Thank you again

Nick
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top