1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

PhotoShop and advapi32.dll error

Discussion in 'Business Applications' started by gvanhouten, Apr 7, 2004.

Thread Status:
Not open for further replies.
  1. gvanhouten

    gvanhouten Thread Starter

    Joined:
    Apr 7, 2004
    Messages:
    5
    Hi all:
    I need your help since I have not been able to find a resolution to this problem. I have a PC running an AMD 1900+ with Win 98SE. I have two CD Rom drives, one regular and another that is a CD RW drive. I have installed Photoshop 7.0 on my machine and it had been working without a problem. I tried to use it last night and I got the following error:

    "Photoshop.exe linked to a missing export advapi32.dll Get effective rights from AclA"

    I therefore thought the dll file had gone bad so I replaced it with a fresh copy. Same problem!!

    I thought the installation went bad, so I uninstalled the program, then reinstalled Photoshop via the regular CD Rom drive and the installation went fine. By the way, I did deactivate the virus program before installation. I then tried to open the program, and I get the above message and another message that a "device is not working". I went into device manager and everything is working fine. Thinking that the regular CD Rom drive was bad, I uninstalled the program, and then installed it using the CD RW drive. Same error message. In uninstalled again, and this time I copied the files from the CD to to c: drive and I then installed from the C: drive. Same error messages. Please help, this has me stumped since the program had worked a couple of month ago without any errors. Since I may not check the forum for a while, suggestions can be sent to my email address:
    [email protected]

    thanks again :)
     
  2. Gram123

    Gram123

    Joined:
    Mar 15, 2001
    Messages:
    1,829
    This is what I could find:

    Info:
    advapi32 - advapi32.dll - DLL Information
    DLL File: advapi32 or advapi32.dll
    DLL Name: Advanced Windows 32 Base API DLL
    Description: Advanced API services library supporting numerous APIs including many security and registry calls.
    Part Of: Windows NT 4.0
    System DLL: Yes
    Common Errors: File Not Found, Missing File, Exception Errors

    As I understand it, Advapi32.dll is a Windows System file that checks the registry in order to support a running program, so your error may be with Windows rather than Photoshop.
    I have read that different versions of Windows have different versions of advapi32, so if you did download replacement advapi32 file, it may have been for the wrong vers of Windows...
    Also read that there are some viruses that can affect the advapi32 file...

    Knowledge Base suggests:
    Don't know who AclA are tho - there are lots of companies with this acronym, but including "Acer Computec Latino America"...

    HTH
    Gram
     
  3. gvanhouten

    gvanhouten Thread Starter

    Joined:
    Apr 7, 2004
    Messages:
    5
    Thank you for your reply. It is in fact a Windows file and I did find other recommendations on the web about replacing other dll files. So I used the file restore option in Windows and did restore this file from the Windows installation disk. Re-booted and now everything is back to normal. Thanks again!! (y) (y) (y)
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/217985

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice