Please help. i dont know what else to do?!

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

elizabethbayb

Thread Starter
Joined
Dec 1, 2017
Messages
1
I have everything done in my gaming pc so i plug in my hdmi to my monitor and connected my mouse and keyboard.
My monitor says no signal, my mouse and keyboard normally light up and they didnt so i checked and made sure they worked as i plugged them into my laptop, they both worked when i did that.
The biggest problem is hdmi, if i can figure out what is wrong i can most likely fix other issue as well for keyboard and mouse.
I tried different hdmi cords.
I tried unplugging and connecting again, i tried restarting.
what am i missing?
 

Johnny b

John
Joined
Nov 6, 2016
Messages
8,844
Check your monitor manual for a selection button that's usually on the bottom right corner of the monitor.
 

737Simpilot

Temporarily Banned
Joined
Jun 25, 2017
Messages
317
I'm not sure why HDMI and the USB ports wouldn't work. That's very puzzling. The only think I can think of is that you have a USB header wrong and the HDMI isn't working because you haven't connected the power to the GPU.

What are the computer specs?
 

Macboatmaster

Trusted Advisor
Spam Fighter
Joined
Jan 14, 2010
Messages
24,723
If by this
My monitor says no signal, my mouse and keyboard normally light up and they didn't
you mean that the mouse and keyboard usually WORK on this computer and do NOT when you connect HDMI, then I doubt it is the usb header although I suppose there is a slight chance of that, but I consider it very slight

We have no details whatsoever of your system and offering suggestions without it is very much a shot in the dark
Presuming that the system works without the HDMI monitor connection send the results of this please as a copy and paste of the info in the white box
https://static.techguy.org/download/SysInfo.exe
 

managed

Allan
Moderator
Joined
May 24, 2003
Messages
15,494
In your post you say "I have everything done in my gaming pc" - does that mean this is a new build and this is the first time it was switched on ?

EDIT : make sure you connected separate power cable to the graphics card if it needs it.
 

Macboatmaster

Trusted Advisor
Spam Fighter
Joined
Jan 14, 2010
Messages
24,723
I agree if indeed it is a NEW build then as previously posted
The only think I can think of is that you have a USB header wrong and the HDMI isn't working because you haven't connected the power to the GPU.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top