1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Please help me get my USB ports working.

Discussion in 'Hardware' started by inferlogic, May 30, 2006.

Thread Status:
Not open for further replies.
Advertisement
  1. inferlogic

    inferlogic Thread Starter

    Joined:
    Jul 22, 2004
    Messages:
    197
    Hi all,

    My usb ports don't seem to be working, and I was hoping someboy can guide me into the right direction to get them working again! here is specs of my PC using the services of Belarc Advisor. If there is any other info you need from Belarc please let mw know.

    Board: First International Computers P4M-800M PCB 1.x
    Bus Clock: 133 megahertz
    BIOS: Phoenix Technologies, LTD 6.00 PG 09/24/2004

    OS: Windows XP Home Edition Service Pack 2 (build 2600)

    Here is what itsays under BUS Adapters
    VIA Rev 5 or later USB Universal Host Controller (4x)
    VIA USB Enhanced Host Controller

    Thanks for any help.
     
  2. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    Did they ever work? If so, what happened right before they stopped working? Do they work for any devices? Have you installed the Via motherboard drivers?
     
  3. inferlogic

    inferlogic Thread Starter

    Joined:
    Jul 22, 2004
    Messages:
    197
    Hi there

    Well I don't believe they have ever been working. well we have only had the computer about 2 or 3 months and since having it there was no need for pluggin any USB devices in. I tried a printer last month and it didn't seem to work so I thought nothing much of it, It was only recently that I tried to download music into my friends Ipod Nano that didn't work and then most recently I have a mobile phone with a USB cable and pc compatability I tried that and that hasn't worked either only to conclude that my USB ports must not be working.

    I have looked in my device manager and I do see that there are USB drivers in there, I did try to reinstall the VIA USB drivers from the website but that hasn't seemed to work.. Oh yea if it helps I remember when I once plugged in the Ipod Nano I rememberd a the USB little ding dong sound it makes but it didnt say new hardware detected or installing hardware, just nothing happened and the device just did not work, I did install the software correctly for all my devices.

    Thanks for any help.
     
  4. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    Well, since it won't really hurt to try it, let's flush out all the USB parameters and reboot for a fresh start, see if that helps.

    Create a file with NOTEPAD containing the following lines and save it as FIX.REG
    -------------------------- cut after this line --------------------------------
    REGEDIT4

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment]

    "DEVMGR_SHOW_NONPRESENT_DEVICES"="1"
    -------------------------- cut before this line --------------------------------

    Double click on FIX.REG and say yes to the Merge Into Registry question.

    Unplug ALL USB devices.
    Open Device Manager.
    View, Show Hidden Devices.
    Uninstall all devices under USB Controllers.
    Uninstall all devices under Disk Drives that you know are not present.
    Uninstall all devices under Storage Volumes. Say no to any reboot prompts until you are finished. Also, if a Storage Volume doesn't uninstall, ignore it and move to the next one.
    If you have a yellow ? with unknown devices, uninstall all of the entries there as well.

    When this is done, reboot TWICE.

    Reconnect the USB devices and see if they're recognized properly.

    NOTE: If you have a USB keyboard and/or mouse, you'll have to modify the instructions and leave enough parts for those to function. I don't have one yet, so I haven't had time to modify the instructions.
     
  5. nick0219

    nick0219

    Joined:
    May 31, 2006
    Messages:
    130
    hey yes i need help on this. The only problem is that Iam on limited rights. I did the FIX.REG thing but I got an error message
    [​IMG]
     
  6. nick0219

    nick0219

    Joined:
    May 31, 2006
    Messages:
    130
  7. nick0219

    nick0219

    Joined:
    May 31, 2006
    Messages:
    130
  8. inferlogic

    inferlogic Thread Starter

    Joined:
    Jul 22, 2004
    Messages:
    197
    Hi John Will

    Well I carried out the fix.reg and did the removal of USB, storage volums etc and after retarting twice I tried plugging in my USB printer and just nothing happened. i looked in the device manager and what i can see is other devices 5 items in there all USB controllers an all with a yellow question marks next to them.

    what does this mean?

    Thanks.
     
  9. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    I think you need to load the VIA motherboard drivers if they are not being recognized.
     
  10. inferlogic

    inferlogic Thread Starter

    Joined:
    Jul 22, 2004
    Messages:
    197
    ok John could you possibly tell me what I need to install because im sure i did it last time.. unless i installed them incorectly? is there a way you hav to install them properly? should I download all the driver for my board and reinstall everything or just the USB drivers?

    Thanks.
     
  11. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    I'd just re-install the MB drivers. Didn't you save them the last time you downloaded them?
     
  12. inferlogic

    inferlogic Thread Starter

    Joined:
    Jul 22, 2004
    Messages:
    197
    Hiya

    I did download drivers last time but with it not working I am wondering If I downloaded for the right motherboard or not.

    Im not quite sure which board i have.... it says this under board in Belarc Advsier
    -----------------------------------------------------------------
    Board: First International Computers P4M-800M PCB 1.x
    Bus Clock: 133 megahertz
    BIOS: Phoenix Technologies, LTD 6.00 PG 09/24/2004
    ------------------------------------------------------------------

    Does that tell you which sort of board it is or would I have to open the case to find out?

    Thanks for help
     
  13. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    I generally go to the VIA site and download the latest 4-in-1 driver set, works with all the VIA chipset boards I've tried it with.
     
  14. inferlogic

    inferlogic Thread Starter

    Joined:
    Jul 22, 2004
    Messages:
    197
    Hi Johnwill

    Ok I tried what you suggested and went to the Via website to downloda the 4 in 1 driver set, installed that and that has had no effect on my USB? this is the lik I used. have I chosen the correct download, if you hit the link and scroll down it says 4 in 1 and thats what i pressed.
    http://www.viaarena.com/default.aspx?PageID=420&OSID=1&CatID=1070

    thanks
     
  15. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    Is your chipset in the list right next to the download?

    The driver package below is recommended for use with the following chipsets: MVP#, Apollo Pro## series, KT1##, KN1##, KM1##, KT2##, KT333, KN2##, KM2##, P4X2##, P4X3##, P4M2##
     
  16. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/471406

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice