1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Plug and play USB scanner stopped working

Discussion in 'Hardware' started by maheshh, Apr 17, 2004.

Thread Status:
Not open for further replies.
Advertisement
  1. maheshh

    maheshh Thread Starter

    Joined:
    Apr 17, 2004
    Messages:
    3
    Hello all,

    I bought a Memorex 48U (same as Artec) some time ago and it was working fine for about 7-8 months. Suddenly one fine day it stopped working. I get the following error:

    TWAIN Error!
    Failed to open the TWAIN driver.

    I have been searching on the web for a while and have come across a whole bunch of people who have this problem with the same scanner. The fix that some of the forums have posted have not worked for me. One forum claimed that following fix has been recommened by Memorex tech support.
    --------------------------------------
    1) Disconnect the usb cable btwn your scanner & PC.
    2) uninstall all the software (go to ctl-panel->add/remove programs)
    3) in explorer, go to %WINDIR%\twain_32 directory... He had me delete my MEMU48 directory here... if you have a differently branded scanner, you may have a different directory?
    4) in explorer, go to %WINDIR%\inf directory -- there are a number of OEM#.INF files here (where # is a number)... go to the highest numbered file, open it with a text editor... if it says MEM48U in there (for my memorex brand), then delete this file AND its associated .PNF file (for example, if you have an OEM4.INF file, you will also have an OEM4.PNF file -- delete them both).
    5) Re-install the software from your CD
    6) RESTART YOUR COMPUTER. (This is what I did not do the first time. Even tho it does not prompt you to restart, DO IT anyway.).
    7) re-attach the scanner with your usb cable.
    8) you should get the found new hardware wizard, follow the prompts to do the final driver steps....
    --------------------------------------------------------------------

    This has not worked for me. I am pretty much helpless and I am hoping that somebody on this forum will have more insight into this problem.

    I am on a Win2K, PIII machine. If more hardware details are required then I will let you know.

    Regards

    Mahesh.
     
  2. Whitestar

    Whitestar

    Joined:
    Mar 22, 2003
    Messages:
    511
    Do you have any other USB devices that have stopped working?
     
  3. maheshh

    maheshh Thread Starter

    Joined:
    Apr 17, 2004
    Messages:
    3
    No.

    Other devices that I have on USB are Logitech camera, Netgear wireless receiver and a port where I always connect my digital camera to download pictures. All these work absolutely fine.


    Mahesh
     
  4. ceri sheeran

    ceri sheeran

    Joined:
    Aug 15, 2003
    Messages:
    894
    Hi,

    Does the scanner have its own separate power supply. If not and is powered off the USB cable only. You may be drawing too much power on the USB bus. Try running the scanner from a powered USB hub.

    hth

    Ceri
     
  5. wolfworx

    wolfworx

    Joined:
    Oct 2, 2001
    Messages:
    1,221
    Two weeks ago I started having problems with my Artec AS6U. It would not work in Win2K or WinXP. I searched for drivers, found several none worked. After spending many hours on the problem, I realized time is money, so I bit the bullet and bought a new HP 2970. Problem solved. BTW, anyone want to buy my Artec cheap? :)
     
  6. maheshh

    maheshh Thread Starter

    Joined:
    Apr 17, 2004
    Messages:
    3
    Scanner does not have its own power supply. Do I have a to buy a powered USB to check it out?

    Do you think something like that may prompt the TWAIN Error! ? It sounds more like a driver/software issue ... I maybe wrong.

    Also, one thing changed sometime around when my scanner stopped working is that I bought a USB hub which let me connect upto 4 devices onto one USB port. But that should not be a problem. All the devices I mentioned before - camera, netgear wireless receiver, etc. are connected into the same hub. Its only this scanner that does not work.

    I thought of getting rid of this scanner. But I have paid 70 bucks for it, (forgot to send in the 60 bucks rebate -- stupid me) and therefore what to see if I can get it back to life.

    Thanks for any help.

    Mahesh
     
  7. Future

    Future

    Joined:
    Apr 17, 2004
    Messages:
    48
    You should check to see if the usb port that the scanner was using is still working.

    You can do this, by plugging in any other usb device that you know for sure is working.

    If it does not work, then it is possilbe the usb port is down.

    If it does work, then the chances are the scanner has simply broken down.

    However, have you installed any software lately? Or any anti virus software etc?

    If you have, either one could have caused a problem with the scanner drivers, unlikely but possible.

    You should restore to a point prior to the installation of any software when the scanner worked.

    If that fails, then re-installing the scanner drivers after they have been removed could solve the problem

    What some people seem to forget though, is that when a driver or application is removed, sometimes bits of code are left in the registry, this to me is bad programming, but some companies do it. They claim it is prevent problems, but causes more than it cures. Norton does this, which makes it rather a long winded way to have to remove it all in order to reinstall it after a failed installation

    well, I hope that helps you some.
     
  8. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/221242

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice