Plumax/Maxtor 2.0 USB hard drive

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Insaino

Thread Starter
Joined
May 28, 2003
Messages
21
I recently oredered a Plumax 2.0 USB external hard drive to help my dad back up his laptop. However I'm unsure exatly how to format the dirve or get it working. Being USB i tried just plugging it into the computer, and was were notified of it running at a reduced speed due to USB 1.0 on our computers. It aslo detected and installed new USB Mass storage device hardware. However it does not show up under My computer as a drive. Under device manager the maxtor HD shows up and says it is working properly, and also it shows up in the USB as mass storage device. I run Win XP and was wondering if i need to format this thing or if its broken? Thanks a bunch
 

JohnWill

Retired Moderator
Joined
Oct 19, 2002
Messages
106,418
The drive is working fine. The reduced speed message is normal when you plug a USB 2.0 device into a USB 1.1 port.

As far as the drive not appearing, it's not formatted! :) Right click on My Computer, select Manage. Select Disk Manager, and find the USB drive in the drive list. Right click on the drive and select Format. When you get done, it'll show up in My Computer.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

No members online now.
Top