1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Prefetch not working

Discussion in 'Windows XP' started by DarrenW, Feb 9, 2003.

Thread Status:
Not open for further replies.
Advertisement
  1. DarrenW

    DarrenW Thread Starter

    Joined:
    Jul 19, 2000
    Messages:
    94
    My prefetch folder is no longer logging data. I've checked the registry settings and all is ok there. Has anyone ever run into this? I occasionally clear the prefetch folder as part of my system maintenance. Was there something I shouldn't have cleared? :confused:
     
  2. Rollin' Rog

    Rollin' Rog

    Joined:
    Dec 9, 2000
    Messages:
    45,855
    Not sure what happened, Is this the key you checked?

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\PrefetchParameters

    The data value on mine is:

    3

    Also, have a little fun with this utility for Windows XP. You should download the Whitepaper and read that for instructions.

    BootVis.exe Tool -- it's under "downloads"

    http://www.microsoft.com/hwdev/platform/performance/fastboot/default.asp
     
  3. DarrenW

    DarrenW Thread Starter

    Joined:
    Jul 19, 2000
    Messages:
    94
    Yes, That key entry is set to 3. To disable prefetching set it to 0. I already use Bootvis (that's actually how I noticed my prefetch didn't seem to be collecting data). I remember reading somewhere that XP only starts populating the prefetch folder after x number of reboots. Does anyone remember how many reboots that was?
     
  4. Rollin' Rog

    Rollin' Rog

    Joined:
    Dec 9, 2000
    Messages:
    45,855
  5. boyoh53

    boyoh53

    Joined:
    Nov 28, 2002
    Messages:
    2,985
    If I remember correctly I once cleared mine completely and the
    folder disappeared for a day or two, then returned.
    Now I always leave a few files in it to keep it there. Perhaps your problem is different. :(
     
  6. geef0rce

    geef0rce

    Joined:
    Aug 9, 2004
    Messages:
    1
    Hi Guys, :p

    I might be a bit late in replying to this post but here is a solution that worked for me!!

    To re-enable prefetch do the following:
    START | RUN | SERVICES.MSC
    Locate "Task Scheduler"
    Double click the service "Task Scheduler"
    Set to run "Automatic"
    Start the Service

    then:

    START | RUN | CMD
    enter:
    Rundll32.exe advapi32.dll,ProcessIdleTasks

    Also, you may want to ck your registry to see if it has been disabled.

    Start > Run > regedit

    Then,navigate through the left pane until you get to this hive:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\PrefetchParameters

    In the right pane, look for the key named EnablePrefetcher. The value of this key represents how prefetch works on your system. Values you can choose from include:

    0—Disable
    1—Application Launch Prefetch
    2—Boot Prefetch
    3—Prefetch everything

    I would recommend you use the '1' value, which is how mine is setup, but considering the amount of RAM you have, you could even push the envelope to '3'.

    Another tip, once you have done the above steps run your disk defragmenter.

    Hope this helps you all!! :)
     
  7. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/117867

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice