1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Print Generic Cadd from USB Printer

Discussion in 'Windows XP' started by Peohguy, Oct 23, 2011.

Thread Status:
Not open for further replies.
Advertisement
  1. Peohguy

    Peohguy Thread Starter

    Joined:
    Oct 23, 2011
    Messages:
    6
    Tech Support Guy System Info Utility version 1.0.0.1
    OS Version: Microsoft Windows XP Professional, Service Pack 3, 32 bit
    Processor: Intel(R) Celeron(R) D CPU 3.20GHz, x86 Family 15 Model 6 Stepping 4
    Processor Count: 1
    RAM: 1014 Mb
    Graphics Card: Intel(R) 946GZ Express Chipset Family, 224 Mb
    Hard Drives: C: Total - 63350 MB, Free - 14510 MB; D: Total - 10179 MB, Free - 1680 MB;
    Motherboard: Acer, E946GZ , ,
    Antivirus: avast! Antivirus, Updated: Yes, On-Demand Scanner: Enabled

    I have Generic Cadd 6.1 which only has the capability of sending its output to a plotter, printer or postscript.
    for printers it can send to printers connected to COM1, COM2, LPT1, LPT2, LPT3, or File.

    I have used mostly a HP LaserJet II on LPT1, but it is getting tired and takes up too much space and I would like to only use my new Lexmark printer Pro 903 All-in-One.

    I have tried following the post I have seen whichis copied below but I am not computer savy enough to figure out how it was really done, can someone tell me step by step leaving nothing out or to the imagination how to make it work?
    To those that can help, I say thanks for your help!:



    Try the free trial version of pdfFactorypro. After installation, you'll see it in your list of installed printers.

    Change the port in the properties...see how that goes, though you may have to change things up to print to lpt2 if your physical parallel port is already assigned to lpt1...and of course a change to the CADD output.

    jdn


    Member with 88 posts. Join Date: Dec 2009
    Experience: Intermediate

    05-Jan-2010, 05:41 PM #15
    Sorry if my message got interupted. IT WORKS Here's what I did. I first disconnected my parallel port connection to my printer and connected it via USB connector. This created a second HP printer which I made the defualt printer and named it USB. Now have 2 Printers, HP and USB.Port setting of HP is LPT3 and port setting of USB is USB-Virtual printer port. I downloaded and installed pdffactory and it's port setting is FPP3- pdffactory. I made this the default printer I tried making a print from CADD. No print. Found that print went to HP and got an error message that it wouldn't print. Of note, The CADD program is set to print to LPT3. Rather than removing HP, I changed it's port setting to LPT2. I also reset the pdffactory port. I checked the Enable Printer Pooling box and checked the USB and LPT3 boxes. I then set pdffactory as the default printer and was able to make a print from the CADD program. I'm going to continue playing with the setting to see if I have thing correct, but it's a big relief to know that if my present printer fails I have a backup position. I can't thank The Hound enough for his effort on my behalf.
     
  2. Frank4d

    Frank4d Trusted Advisor

    Joined:
    Sep 10, 2006
    Messages:
    9,126
    This article discusses printing to a network printer, but also works for a shared local USB or ethernet connected printer: http://support.microsoft.com/kb/314499

    When used on a local connected printer, "Printserver" is the computer name, and "Sharename" is the name of your printer in printer properties.
     
  3. Peohguy

    Peohguy Thread Starter

    Joined:
    Oct 23, 2011
    Messages:
    6
    Frank4d,
    Thanx for the information and directing me to the information on print servers. Since I haven't set up my printer on a network yet, it may take me a while to stumble through it, but when I do I will let you know if it worked.
    The major question that is still lingering on my mind, however is that when printing a drawing from Generic Cadd to a printer, I have to identify what printer I have which I identify from a list of printers that Generic Cadd provides. I'm not sure if these are correctly called printer drivers, but they do contain a list of all of the crontol codes that a particular printer uses for line feed, line space , line length, page length, line color, etc. all in a particular order. Since my new Lexmark printer is not on the list I am not sure how I can configure Generic Cadd to send out the right control codes for a Lexmark even if I can redirect the output from LPT1 to USB. I really feel like I'm in deep water here and am not even sure if I No how to ask the right questions, since I dont know how to make my Lexmark emulate any of the printers on the list (if that is even possible) or if I need to make up my own file with the Lexmark control codes and where can I get them since the manual does go into that sort of detail.
     
  4. Peohguy

    Peohguy Thread Starter

    Joined:
    Oct 23, 2011
    Messages:
    6
    fRANK, thanks for helpING me.
    I did finally figure out how to follow the instructions given at [COLOR=#f8941d !important][COLOR=#f8941d !important]web [COLOR=#f8941d !important]site[/COLOR][/COLOR][/COLOR] http://support.microsoft.com/kb/314499, titled “How to print to a network printer from an MS-DOS-based program in Windows XP” and I was able to correctly write the use net instruction to redirect my ouput from LPT2 to my Lexmark USB connected printer, once I used the “Full computer name” instead of the “Computer description” for “printserver”. After I exited from DOS command, after redirecting LPT2 I opened up my Generic Cadd program, then opened a drawing file, then went to print it out after making sure that LPT2 was selected as my print output, and my drawing was centered and scaled to my [COLOR=#f8941d !important][COLOR=#f8941d !important]paper [COLOR=#f8941d !important]size[/COLOR][/COLOR][/COLOR], I hit output and lo an behold after several seconds my Generic Cadd program minimized and my printer came on and spit out a single blank sheet of paper and I got the message on my Lexmark printer "Printhead Error”
    I then followed those instructions to clear the [COLOR=#f8941d !important][COLOR=#f8941d !important]error[/COLOR][/COLOR] and had no joy, so I went to the Lexmark site and emailed them about my [COLOR=#f8941d !important][COLOR=#f8941d !important]printhead[/COLOR][/COLOR] problem (I really didn't have the time to talk to someone at that time amd I would rather have a thought out answer rather than a verbal hip shot). I have only owned the printer for 2 weeks! I don’t think the redirection from LPT2 to USB caused the printhead problem, but what do I know?
    So I really don’t know if redirecting LPT2 to USB will work or not for printing out Generic Cadd drawings. I will let you know once my printer is up an running again, IF.
    Best regards and I will keep you posted when I find out anything,
    Peohguy
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1023684