1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Print/Spooler Registry Fix

Discussion in 'Windows XP' started by wfkuhn, Mar 20, 2006.

Thread Status:
Not open for further replies.
Advertisement
  1. wfkuhn

    wfkuhn Thread Starter

    Joined:
    Mar 20, 2006
    Messages:
    1
    The other day I was cleaning up my registry (carefully I might add) deleting junk I knew was junk. A day or so later I needed to print and lo and behold there were no printers on the control panel and I kept getting an error 1068!!!!!!!!!!!:eek: So for the last day or so I have delved it to the morass of printer/spooler problems on the net. Well today I finally fixed the problem. :D

    A while back our old Lexmark inkjet went south. So the other day I uninstalled the Lexmark miscellaneous programs/drivers. When I was cleaning up the other day some (lex***.***) entries were still in the registry so I deleted them also. I checked B4 I deleted any, on the internet to be sure each deleted key was not “important”.(y)

    After considerable browsing on the internet I was lead to check the spooler which I found was NOT started.:confused: Using services.msc I set all the recovery settings to "restart the service" but when I tried to start it again I received the error “lack of resources” and it stopped itself. It now became a bit frustrating.:mad: After 2 days of browsing I found an obscure HP fix for another similar error which was directly related to Lexmark printers. :)

    Apparently in the registry at:
    HKEY_LOCAL_MACHINE\SYSTEM\currentcontrolset\service\spooler
    the key “dependonservice” when loading a Lexmark printer is set to “lexbcse.exeRPCSS”. Seems when you de-install the Lexmark stuff this key is NOT deleted and restored to its default value “RPCSS.” All I did is delete the :lexbcse.exe" part, rebooted and the spooler started again :p

    Hope this helps someone!
     
  2. vois2

    vois2

    Joined:
    Jul 16, 2005
    Messages:
    2
    Well two years later your fix was indeed helpful to me. It did the trick. On this desktop a Lexmark printer had never been installed, or used ever. So I don't know why that Registry key was found to be exactly as you described it to be, but it was.

    And to note this was after I had used the cleanspl.exe tool from the Microsoft Resource Kit.

    Thanks!!
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/451388