1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Printer software problems

Discussion in 'All Other Software' started by starchild, Jan 3, 2006.

Thread Status:
Not open for further replies.
Advertisement
  1. starchild

    starchild Thread Starter

    Joined:
    Sep 17, 2002
    Messages:
    2,111
    I'm thinking this might be for hardware, but I got the printer (drivers) itself working, it's the rest of it that's not there.

    This started when I put in PrimoPDF, a program recommended on a Publisher group, for saving Publisher files to show someone who doesn't have that program. I couldn't get it to work, and googled it (and wrote about it here) and found directions for how to get it installed with Win 98 which seems to be a problem.

    http://forums.techguy.org/business-applications/430187-setting-up-primopdf.html

    I had it working, clicking print would bring up the print box, and the menu would show the printer, the Primopdf (which saved it as a pdf) and my Ring Central Fax.

    I didn't know till today, when I got a fax and tried to print it, the printer was no longer working. Error message, the computer isn't communicating with the printer, try unpluging it, restarting, etc. (it's a Lexmark All in one 5150- using the USB and yes, I know it's cheap junk, but it was all i could afford at the time :) It's been working good, scanning, faxing, photocopying and printing till I put the PrimoPDF in. In SETTINGS> PRINTER the printer was greyed out and the Ring Central fax (and add a printer) was showing.

    Since I wanted to print the fac I got (for someone else) I uninstalled the Primo- the printer still wouldn't work, I uninstalled the all in one and installed it from the CD, still didn't show

    With this printer you don't let windows detect the hardware,(or "set up new printer") just use the installation CD. I remember that from when I got it (last year) but can't find specific directions for putting the software in. All the manual has is about how to use it.

    I also have an ujpdated driver- software I once got online and had put in, so tried that tonight also.

    I went in and took the files out of SYSTEMS the directions for installing Primo had said, and after that the printer went in.

    So, the printer is in and works, but I don't have the "all in one center" that's supposed to be there to use for scanning and faxing. When I click on the shortcut link (from before) the flashlight comes up and says it can't find the lxbaaivx.exe file. That's how the spelling looks to me. I put it in FIND and nothing.

    I've uninstalled and reinstalled, and can get the printer in (and set as default) and it works when I click PRINT, but there's no All In One Center to open with options for scan, fax, etc.

    In the files I see a fax to set up, and started to, but it's not what I used before (Ring Central Fax would come up) and there's nothing to set up for the scanner that I can see.

    It's late and I've been going in circles with this for hours. At least the printer now works.

    I can get a "solution center" up, that tells HOW to do things (like scan and fax) but they all say to click on the All in One Center and open this. It said to find this go to Start> programs> Lexmark> all in one center. But, it's not there.

    I looked in device manager (not really knowing much about it) and it says the Lexmark printer is on one of the USB ports. (I have a San disck, drive for a memory card from my camera on the other port) Since that's all installed with software, I just left that in while I did the printer.

    Anyway, the printer seems to be in and working, it's the software (all in one center) that's just not there.

    Any ideas I can try tomorrow? I have WIN 98SE.

    Been a long day and I'm tired of trying this and seem to be missing something,(with what I'm doing) but I don't know what.

    Thanks,
    Carrie
     
  2. panamahat

    panamahat

    Joined:
    Apr 30, 2005
    Messages:
    340
    Something similar has happened to me, Carrie. My HPpsc2410 Photosmart stopped working and, needing to get something out, I hooked up my backup Canon IP1000 Pixma. Lo and behold, same problem. Like you, I've gone through all the attempts to reinstall but neither program will recognize the hardware. I've also restored the system twice. No effect. I've been all over the HP site and the internet in general trying to figure out what on earth (or extra-terrestrially) is going on. So far, nada, nada, nada.
    I'm in Panama so the thought of having to deal with possible hardware repairs with my limited Spanish is frightening. :eek: My computer is a Toshiba 5005-S504 Satellite Laptop. OS is XP Home.
    Any help very much appreciated.
    Jane
     
  3. starchild

    starchild Thread Starter

    Joined:
    Sep 17, 2002
    Messages:
    2,111
    I found something in google and found something about it, but it was for Win 2000 (and I have 98SE) Said if the All in One Center wasn't showing. I decided to try it anyway (it didn't say just for Win 2000)

    Said to insert Lexmark CD, open, double click drivers and scan (folder) right click on gliplus.dll and open with- select Winzip, extrat file to C:\WINNT

    I did this, it didn't seem like it extracted it (unless it did it instantly and didn't show anything) and nothing changed.

    I wrote to Lexmark customer tech support, and got an auto response saying they will answer if and when they can.

    In the meantime I downloaded an update to my Zone Alarm, it says it can't be installed because the MSIMG32.dll file is missing. I tried restoring it from a WIN 98SE cd of files I have and it says it's not there. I ran system file checker and it doesn't say anything's missing. I tried replacing it from the CABS (I only know a little bit about) using the system file checker and it says there isn't one. I downloaded it and extracted it (again it didn't seem like it did anything) now the Zone Alarm says the MSIMG32.dll needs GD132.dll

    I realize Zone Alarm is another topic and I'm not worried about this, but maybe the missing dll files are related to the printer.

    The last time I restored WIN 98 SE from the full restoration CD I had to do it 12 times (over several days) to get it right and get everything to set up. I finally downloaded some Windows patches that helped. I don't want to do this again if I don't have to.

    But, seems like now I have dll files missing.

    I once got directions (on here) for reinstalling Windows from the CABS, that left the files, and programs, etc. intact (not wiping it all out). Maybe I can find it again and try that. But, the origainal cab files would have to be on the computer somewhere to reinstall from.

    It's frustrating to try and do something and not really know what you're doing.

    I got a fax in last night (I don't use it much, but was doing it for someone else) then wanted to scan and fax the paper on elsewhere. Which was when I discovered all this.

    Today, I can use the printer to PRINT but there's no All in One Center to go to, to use the options Fax or Scan.

    Yours is a different printer (s) Maybe someone who can deciper all this can give us simple directions about what to try.

    Thanks for sharing, at least we don't feel so alone :)

    ~ Carrie
     
  4. panamahat

    panamahat

    Joined:
    Apr 30, 2005
    Messages:
    340
    Frustrating is definitely the word for it but this forum has helped me before. I have a lot of faith in the folks here so I'm telling myself to be patient and to stop screaming at inanimate objects. Meanwhile, like you, I am continuing to try different things. Fingers crossed for both of us!
     
  5. starchild

    starchild Thread Starter

    Joined:
    Sep 17, 2002
    Messages:
    2,111
    I have a HP Brio computer but never had a printer (that brand)

    I think mine has more to do with my computer than printer.

    I have faith in the people who help here, too. In spite of the fact I don't think I'm always clear in how I ask (LOL)

    ~ Carrie
     
  6. panamahat

    panamahat

    Joined:
    Apr 30, 2005
    Messages:
    340
    Carrie: I just received a reply to my post (separate from your thread) "Both Computers Down." Jeff suggests going to the Registry and looking for something that shouldn't be there. The registry isn't my strong suit but maybe it is yours....
     
  7. starchild

    starchild Thread Starter

    Joined:
    Sep 17, 2002
    Messages:
    2,111
    >>>>Jeff suggests going to the Registry and looking for something that shouldn't be there. The registry isn't my strong suit but maybe it is yours....


    HAHAHA

    I don't think it's mine either.

    Actually, when I put in the PrimoPDF (that was recommended to me on a Publisher newsgroup, it saves the Publisher files as pdf, so someone who doesn't have Pub installed can then see them) it wouldn't work, it woudln't show the the program. You use it by clicking print then scholling on the menu on the print box, which shows the printer and on mine also showed Ring Central Fax, to Primo PDF. On mine it didn't show. I read a fix for this (elsewhere) with Win 98, so I tried it. It involved moving two files from the Primo folder into SYSTEMS and adding a new entry to the registry. I've done reg stuff if I have directions, so managed to get the new key in (in the PRIMO entery) and the primo showed on my printer menu and worked! I thought this was great till I found my printer no longer worked. (and it was set on the printer, it went back to that by default). I uninstalled the Primo (figuring I'd rather have a printer-scanner-fax than pdf, and I think there are other programs for this) and the printer still didn't work. I deleted the 2 files I'd put in Systems, and looked in the reg and the primo entry (with what I had added) was gone. Must have been taken out with the uninstall. After that the printer would be there, but the All in One center (for choices of fax and scan) wasn't there. It's supposed to put an icon for it on the desktop when it installs and apparently doesn't. When I click the link I had for it (from before) it can't find it... All of which I've written about here.

    I maybe should have stayed in the first thread, where I wrote about the problems getting PrimoPDF to work (it doesn't seem to go good with Win 98, but doesn't say it's for newer only). But, I asked about that in the office topic and it seems to have moved to software now. Or maybe Win 98.... I seem to be missing dll files.

    I'm about as good with missing files as I am with the registery. I keep telling myself "I can do this, it can't be THAT hard". With computers, the trick is to pretend you know what you're doing, just keep trying things and hitting keys (with confidence). I think they know when we're insecure and confused.... (don't laugh someone told me there was a study done that showed a relation between computer problems and the state of mind of the user)
    Sort of like a Sci Fi movie about the future.

    I'm going to see if I can find reinstall Windows through the cabs. I get to the point where I want to fix it and get it to work just to fix it and get it to work! (maybe it's an escape from the reality of housework)

    ~ Carrie
     
  8. starchild

    starchild Thread Starter

    Joined:
    Sep 17, 2002
    Messages:
    2,111
    This is a reply tyo my post about another subject (another time) I don't know how to post the link to just ONE post in a thread so will just copy it
    -------------------------
    JSntgRvr
    Distinguished Member Posts: 4,736
    Join Date: Jul 2003
    Location: Puerto Rico
    Experience: Advanced

    Lets reinstall throughout the cabs:

    Disconnect all peripherals from the computer. Only your monitor, keyboard and mouse should be connected.

    Start the computer and Tap on F8 to reach the Startup Menu. Select Safe Mode Command Prompt Only. At the prompt type the following and press Enter:

    Find /I "ProductKey" C:\Windows\System.dat

    This will give you the Product Key that you will need for the rest of the process. Write it down.

    At the prompt type the following and press Enter after each line:

    cd\windows\options\cabs
    Setup

    Follow instructions on Screen for installation. Have the ProductKey handy for activation. Let us know the outcome.
    -----------
    (I did the product key but didn't need it and have it writtenon the front of the Win 98 booklet, also)

    I wonder if this would help? This would reinstall Win without taking my files out. But, the files would have to still be there to reinstall (I'm lost in this)

    I think I will take out the printer and put it back in one more time, it's another day and sometimes this works. Just trying it one more time. With a different attitude?

    Of course, right now I have the printer itself working (just not fax and scan). Maybe I should quit while I'm ahead.

    ~ Carrie
     
  9. hansmax

    hansmax

    Joined:
    Nov 26, 2002
    Messages:
    690
    My Lexmark X-83 has given me no end of grief, but works pretty well - kind of a love-hate thing. I have similar problems and find that a restart often does the trick. A lot of times you can go through the reinstall and it seems like it didn't work, but on the restart WinXP will say that it found new hardware, and then go ahead and install the drivers and it works. I know it's an overly simple answer, but I have learned to save a lot (not all) of the grief just by turning the computer off and on again. I got tired of uninstalling and reinstalling the Lexmark crap because it takes so darn long. Next printer will be some other brand, which will no doubt give me all kinds of grief, too. Ain't life grand.
     
  10. panamahat

    panamahat

    Joined:
    Apr 30, 2005
    Messages:
    340
    Carrie -- I am going to stop experimenting. Have now messed up my computer so badly it will not restore to any date, is stuck trying to install some unknown scan and has generally kicked me in the teeth. Maybe I will feel differently when I calm down. In the meantime, good luck to you.
    Jane
     
  11. starchild

    starchild Thread Starter

    Joined:
    Sep 17, 2002
    Messages:
    2,111
    jane, don't give up try again tomorrow.

    For some reason, I tried again today (first I right clicked on the C drive and properties and did disk clean up thinking maybe something left over somewhere was in the way) then put in the Lexmark software (newer version I got online at one time, but I'd tried this too, yesterday) and this time it worked. The license agreement came up which I hadn't seen before. Also, Windows starts in saying it detects new hardware and is installing drivers for it, (I think this might be the printer port, the Lexmark installs on the USB) and I kept trying to get that off. I remembered from the original Lexmark instructions to use install from the CD and not the windows set up printer, etc. (because it also has scan and fax)
    So, now it works the way it should (so far)
    But, when I start up (the computer) I get an error message saying "The MSIMG32.DLL file is linked to missing export GD132.DLL GdGradientfill. Which sounds like something from an art program! (I have several installed, but they're not open or opening at the time)
    I don't want to give up on your printers! Someone just has to read it and point you in the right direction.
    I was thinking earlier that maybe trying to install one of them might work. Go to Add/Remove programs and take them both out, and start from scratch. I don't know anything about any other printer (my previous one was a Canon BJC-250 I had for 6 years which installed through the add printer, and "have CD")
    Last year I reinstalled Win 98 (SE) in this, with the full restore CD, 13 times over several days time (which much writing about it here). The USB ports wouldn't work, and other things didn't seem right, so I'd reinstall it again. I'd start putting programs back in and find something didn't work right, and redo it again. Even doing it through the cabs didn't help.
    At one point I did it, and everything seemed to work.
    Maybe, in my case the hardrive is getting old.
    I don't know anything about newer Windows. But, sometimes it just seems like wiping things out and cleaning up and starting again (and not worrying about it) works. I've had this happen many times. Something will start to work, and I don't know why.
    Tomorrow is another day.

    Check in and let me know how it's going. I know how frustrating it can be.

    Thanks, Hansmax, I have had the not communicating with the printer before and it says to unplug and plug in (which usually works) or restart the computer (which also works if the first doesn't) but this last time nothing worked. I thought reinstalling the software would do it. Well, it did, but not till the 2nd day.

    Just think if we all had macs we'd have no problems (according to mac users) but we'd be like the Maytag washer repairman in the commercials, all alone. This way we get to write to others and share (and learn)

    I always think if macs are so good and never need fixing, why don't people just use them and not follwer PC users around telling them this? (LOL)

    ~ Carrie
     
  12. panamahat

    panamahat

    Joined:
    Apr 30, 2005
    Messages:
    340
    Carrie -- I have an ancestor who once said -- with a sword through his jaw so probably he mumbled something off-color and his press-person "interpreted" -- "Never Give Up." I'm with him! I'm also with you on cleaning, restarting, etc. which I'm preparing to do in abundance. We have 4 hours left in this day!!!
    Jane
     
  13. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/430888

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice