problem copying data to an external device

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

blitzkreig

Thread Starter
Joined
Mar 5, 2009
Messages
824
hello,
i recently bought a seagate freeagent goflex 1tb portable hdd, when i connect this to my desktop and copy some file from my local hard drive it says it could not copy the file because the device is not ready, this problem doesnt occur when i connect the portable hdd to my laptop. it has something to do with my desktop pc. please help me diagnose this issue.
 
Joined
Nov 20, 2010
Messages
7
Plug it in and check device manager for potential problems. Run > devmgmt.msc. Sounds like a device problem.
 
Joined
Nov 20, 2010
Messages
7
Yes, I see. So there must be a problem with the desktop drivers. Try their website for a driver update :)
 

blitzkreig

Thread Starter
Joined
Mar 5, 2009
Messages
824
i did install the software that came with the portable, it didnt help :(
 

crjdriver

Moderator
Joined
Jan 2, 2001
Messages
42,041
OK, first of all, there are NO drivers needed for a usb type external drive in any modern os. XP, Vista, Win7, Win2k all have native support for external usb type drives.

The suggestion to check device mgr is a good one. Post a screenshot of device manager. Next do other usb type devices work in this system?

BTW using the included software that often comes with these external drives is asking for problems [IMO] If you want to simply backup files, then just copy them. If you want to backup the complete system drive, then the only thing to use is acronis true image. Either way you do not need the included software [unless it has a free version of acronis like WD offers]
 

blitzkreig

Thread Starter
Joined
Mar 5, 2009
Messages
824
ok, here is some update, my pc technician came and did something (dont know what lol), so things are working for now. will get back incase i encounter this issue again. thanks for your patience :)
 

blitzkreig

Thread Starter
Joined
Mar 5, 2009
Messages
824
ok, i take my words back, the problem still persists. :( need help desperately
 

blitzkreig

Thread Starter
Joined
Mar 5, 2009
Messages
824
not working,
i have a power surge issue on my usb ports.... none of my usb devices function properly. I guess i'm facing problems because of the power surge.
 

Attachments

crjdriver

Moderator
Joined
Jan 2, 2001
Messages
42,041
OK, at least you have found your problem. If you are using the mb in your computer specs [msi] then it gives you an excuse to get a quality board such as asus or gigabyte.

If you do not want to get another board, you could just disable ALL usb ports and install a pci usb card like this one.
http://www.newegg.com/Product/Produ...5108012&cm_re=usb_card-_-15-108-012-_-Product

Also make sure you have a quality pw supply such as corsair, seasonic, pcpower&cooling, etc. A poor quality pw supply can cause all types of mb problems.
 

crjdriver

Moderator
Joined
Jan 2, 2001
Messages
42,041
It comes with a user manual however generally you are going to shutdown and insert the card. Pw ON and see if the os has a native driver for the device. If it does, it will load the driver and you are good to go. If not, then you will have to load the driver from a support CD or perhaps download it from the device maker's site.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top