1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Problem detecting external hard drive

Discussion in 'Hardware' started by mogz, Nov 30, 2006.

Thread Status:
Not open for further replies.
Advertisement
  1. mogz

    mogz Thread Starter

    Joined:
    Nov 30, 2006
    Messages:
    9
    I have recently purchased a Samsung SP2514N external hard drive. I have windows xp. I have installed it using the windows installation wizard. When i click on My computer it does not show up but when i click on safely remove hardware i am given an option to eject ‘USB disk – Samsung SP2514N'. And when i right click My computer/ Device manager/ Disk drives it shows Samsung SP2514N. I have tried updating the driver but nothing has changed. Can anyone explain to me how can I save my data to the external hard drive?

    Thanks

    Mogz
     
  2. Parkman

    Parkman

    Joined:
    Nov 30, 2006
    Messages:
    279
    I would try to see if the disk is formatted in disk management. To get to disk manager, right click my computer, go down and select manage. Once in the Computer Management utility, go to Disk Management, your External should show up there as an unallocated disk. On the Bottem part of the split screen right click the area with the diagnol lines. If your disk is not initialized go ahead and do that, make it a primary partition, select the drive letter and such, and select quick NTFS Format. If you have any CD rom drives it will skip letters for those drives, then give you the next letter.
     
  3. justfei

    justfei

    Joined:
    Mar 15, 2005
    Messages:
    318
    yes id have to agree with Parkman. when i first obtained my very first external hd i had the same exact problem and i managed to sort it out at the disk management.
     
  4. mogz

    mogz Thread Starter

    Joined:
    Nov 30, 2006
    Messages:
    9
    Cheers for that i have now got it to work.

    Thanks
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/522770

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice