1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

problem isntalling legacy ATI driver on win7 x64

Discussion in 'Windows 7' started by sacabonos, Apr 20, 2012.

Thread Status:
Not open for further replies.
Advertisement
  1. sacabonos

    sacabonos Thread Starter

    Joined:
    Jan 23, 2009
    Messages:
    9
    Dear all,

    I'm getting frustrated here.. this is taking weeks now and I tried everything I know to resolve the problem but no luck so far.

    I have ATI x1950 pro VGA card and I need to install its driver on windows 7 x64

    I tried installing the legacy 10.2 driver downloaded from AMD website but after installation I restart the PC, I see the windows 7 loading logo then I can't see the welcome screen but I hear windows startup sound! to be able to see my desktop again I have to hard restart the PC and login to safemode and remove ATI driver (which shows under unknown devices)

    The problem isn't with ATI driver only it seems that I can't see my desktop with (microsoft's Standard VGA Graphics Adapter driver) also (check attached image)

    I tried removing ATI driver and clean the system with "AMD Catalyst TwL Cleaner v3.9.2" but I got the same problem after using.

    Please help how do I fix this problem?
     

    Attached Files:

  2. Mark1956

    Mark1956 Malware Specialist

    Joined:
    May 7, 2011
    Messages:
    14,142
  3. sacabonos

    sacabonos Thread Starter

    Joined:
    Jan 23, 2009
    Messages:
    9
    Hi Mark1956, I'm really sure about my graphics card model and driver, this is not my first time installing it, but its the first time to get a problem like this. thanks for your suggestion.
     
  4. Mark1956

    Mark1956 Malware Specialist

    Joined:
    May 7, 2011
    Messages:
    14,142
    Have you used the same card and driver under 64bit windows before as that can cause a problem if the driver is unsigned.

    Tell me the history of this problem, have you just reinstalled Windows or have you moved the graphics card to a new system.
     
  5. sacabonos

    sacabonos Thread Starter

    Joined:
    Jan 23, 2009
    Messages:
    9
    I have this card installed in my PC for long time now, and no its not the first time installing on win7 x64 bit. But you have made me think of something here.. I think I was using a bit older driver 9.2 or 9.3 I don't really remember.. I'll try to install 9.2 driver and see if it fix the problem.

    Edit:
    I have just tested 9.2 driver but its giving me the same problem
     
  6. Mark1956

    Mark1956 Malware Specialist

    Joined:
    May 7, 2011
    Messages:
    14,142
    I have one more suggestion and if this does not work I would start to suspect the graphics card has developed a fault, testing it in another PC would be a good way to find out.

    Follow this:
    With the power disconnected, remove the graphics card and clean the contacts with a soft pencil eraser and blow out the slot on the motherboard and the cards fan/heatsink with a can of compressed air (available from any computer store). Refit the card and continue with this:


    • Download the latest graphics driver for your card and version of windows and save it to the desktop.
    • Go into Control Panel and select Add/Remove programs (XP) or Programs & Features, look for any software related to the graphics card and uninstall it.
    • Go into Device Manager and locate the graphics card under Display Adapters, right click on it and select Uninstall.
    • Run through this routine and locate any/all graphics drivers and delete them. Do not reboot, just close all the boxes to get back to the desktop.
    • Double click on the driver that you saved to your desktop to install it.
    • Now reboot and check the PC's performance.
     
  7. sacabonos

    sacabonos Thread Starter

    Joined:
    Jan 23, 2009
    Messages:
    9
    Hey Mark1956, I took the VGA card apart and cleaned it with compressed air and I cleaned the motherboard slot then I followed the steps but still the same problem. Just to be sure I installed the VGA card on a different computer with windows xp x86 driver and it worked correctly. I guess its a problem with the drivers then!! any suggestions?

    Edit:
    One more thing I need to add, while following the old driver removal instructions under unkown devices I found a driver for ATI 5700!!! I have removed it, but this made me remember the history of the problem. I had this card working with the current windows installation just fine, but I wrongly installed a new generation of ATI drivers thinking that I'm updating my legacy driver, and here is where the problem started.. hope this makes things a bit clear. and this also stress on bad driver problem and not the VGA hardware problem in my opinion.
     
  8. Mark1956

    Mark1956 Malware Specialist

    Joined:
    May 7, 2011
    Messages:
    14,142
    I must admit I am running out of ideas and am getting close to a pont where I would need the PC in front of me to go much further.

    What happens if you uninstall the ATI and the microsoft driver and then reboot into Normal mode?
     
  9. sacabonos

    sacabonos Thread Starter

    Joined:
    Jan 23, 2009
    Messages:
    9
    Windows loads normally and it start installing Standard VGA Driver then I end up with the screen in the first post. (Standard VGA driver under unknonw devices and video controller under other devices)
     
  10. Mark1956

    Mark1956 Malware Specialist

    Joined:
    May 7, 2011
    Messages:
    14,142
    Graphics drivers are a regular source for problems.

    From your last post it looks like this could be due to Windows automatically installing its standard VGA driver.

    You can stop this by following this guide:

    • Click the Start button, and in the Search Box type View advanced system settings. Now hit Enter.
    • Under the Hardware tab click on Device Installation Settings.
    • Then click on the circle next to No, let me choose what to do.
    • The click on the circle next to Never install driver software from Windows Update.
    • Click on Save Changes and close the Windows.
    Once you have done that follow the previous routine and remove all the drivers, and uninstall the Microsoft Standard VGA driver. Then install the driver for the card and reboot.

    Hope this has some impact.
     
  11. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1050079