1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Problem with 8800 ultra

Discussion in 'Hardware' started by Iclipse, Oct 30, 2008.

Thread Status:
Not open for further replies.
Advertisement
  1. Iclipse

    Iclipse Thread Starter

    Joined:
    May 7, 2008
    Messages:
    25
    I recently bought a 8800 ultra gfx card and when i fit it and boot up my computer, a loud constant beep/screech noise goes off and doesn't stop unless i turn off the computer, the computer doesn't load up either, screen just stays black and this noise continues.
     
  2. BG-0

    BG-0

    Joined:
    Dec 31, 1969
    Messages:
    6,922
    Could you post your full system specs, as well as telling us why you bought a 8800 Ultra when you can get a better card, Radeon 4850 for cheaper. :)
     
  3. Iclipse

    Iclipse Thread Starter

    Joined:
    May 7, 2008
    Messages:
    25
    2Gb RAM
    3GHZ dual core processor
    8800 Ultra
    160GB hard drive



    and purely to spite you
     
  4. Elvandil

    Elvandil

    Joined:
    Aug 1, 2003
    Messages:
    51,988
    Does the machine work OK with the old card? Is the new one touching anything?
     
  5. BG-0

    BG-0

    Joined:
    Dec 31, 1969
    Messages:
    6,922
    That wasn't full, mostly I would've liked to see your power supply and motherboard model... What was your old vid card?
     
  6. Elvandil

    Elvandil

    Joined:
    Aug 1, 2003
    Messages:
    51,988
  7. crjdriver

    crjdriver Moderator

    Joined:
    Jan 2, 2001
    Messages:
    38,692
    Before anyone can help you, you need to list exact specs; ie make and model of board, cpu, brand and speed of ram, brand and wattage of pw supply, etc, etc.

    As posted above, go back and recheck the installation of the card. Make sure it is not pushed up against something such a northbridge cooler, etc.
     
  8. Gulo Luseus

    Gulo Luseus

    Joined:
    May 12, 2007
    Messages:
    2,458
    The screetch you hear is coming from the 8800. I know it well, having managed to do it a few times myself.
    On the graphics card you have connectors directly to the power supply. If there is no connection here ( the power supply isnt connected) or there isnt enough power comng to the card, the screetch comes on- I think its a warning system. #this explains the black screen- the card is putting out any signal.
    Firstly check that the power supply is connected ( you may need an adaptor cable for it which should come with the card) from a molex to a 6 pin input. For the ultra, recommended is a MINIMUM 500W PSU with 35A on the 12V rail.
    Check you have the cables in, and that your PSU meets the min spec, bearing in mind anything else you have in the rig.
    Pretty sure one of these is the prob :)
     
  9. Iclipse

    Iclipse Thread Starter

    Joined:
    May 7, 2008
    Messages:
    25
    That would probably explain things, my old card was an 8500gt and am using it right now. The power supply is 450W which i guess is too little
     
  10. BG-0

    BG-0

    Joined:
    Dec 31, 1969
    Messages:
    6,922
  11. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/764261

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice