1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Problem with Clevo M54N laptop

Discussion in 'Windows XP' started by mr.dom.rocks, Nov 8, 2007.

Thread Status:
Not open for further replies.
Advertisement
  1. mr.dom.rocks

    mr.dom.rocks Thread Starter

    Joined:
    Nov 8, 2007
    Messages:
    6
    I bought a laptop from Novatech, it's manufacturers model number is the M54N. My one and only issue with the laptop is that it likes to shutdown without warning, no warnning screens just shuts down like you have just pulled all power from the system.

    I did not have this problem until well after the 28 days return/refund period was over. I have spoken to their tech support several times, and they say the same things. I stated what I was doing at the time of it shutting down.

    The first few times I was just chating on Messenger, Surfing and on MIRC. Then I got into Guild Wars, I know already that my graphics card is being pushed hard while playing it. Due to it only being a Mobile Intel 945GM Graphics Card.

    I was later told to buy a Cool Mat to keep the air cool under the processor fan cool etc this possibly being the cause of my laptop shutting down.

    I wanted to ask those with more knowledge and possibly finding out why it is happening. I have only one choice available to me at this time. And that is to send it back for testing and repair. Which is what Novatech told me in a reply to a complaint email I sent them.

    I'm hoping someone here has some knowledge of Clevo products or of anything like this happening with other brands.

    Thanks in advance!
     
  2. DaveA

    DaveA Trusted Advisor Spam Fighter

    Joined:
    Nov 16, 1999
    Messages:
    16,310
    First Name:
    David
    Is this happening when you are on batteries or plugged into the power?
    If batteries how long have you been using the computer?
     
  3. mr.dom.rocks

    mr.dom.rocks Thread Starter

    Joined:
    Nov 8, 2007
    Messages:
    6
    I was running from mains power. I have had the laptop since the beggining of May this year.
     
  4. mr.dom.rocks

    mr.dom.rocks Thread Starter

    Joined:
    Nov 8, 2007
    Messages:
    6
    I dont want to double post.

    But any ideas?
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/649431

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice