1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Problem with command mode

Discussion in 'Windows XP' started by arungoogol, Dec 28, 2010.

Thread Status:
Not open for further replies.
Advertisement
  1. arungoogol

    arungoogol Thread Starter

    Joined:
    Mar 2, 2010
    Messages:
    41
    I've recently installed strawberry perl

    after that when i use command prompt i cant use command like ping, ipconfig

    if entered those commands it says it is not recognizing as internal or external command


    NOTE: PLEASE FIND ATTACHMENT
     

    Attached Files:

    • c.JPG
      c.JPG
      File size:
      72 KB
      Views:
      91
  2. TheOutcaste

    TheOutcaste

    Joined:
    Aug 7, 2007
    Messages:
    9,028
    Sounds like you may have modified the path variable.
    Open a Command Prompt and type PATH, then press Enter.
    Post the result.
     
  3. arungoogol

    arungoogol Thread Starter

    Joined:
    Mar 2, 2010
    Messages:
    41
    Yes Mr. Theoutcaste

    if i typed path

    it shows a path of perl root files, how to change it default and also i need to execute perl programs also, hope u understand the situation.

    Advance Thanking you.
     
  4. TheOutcaste

    TheOutcaste

    Joined:
    Aug 7, 2007
    Messages:
    9,028
    The default path is:
    Code:
    C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;
    Plus anything any other programs may have added. No way to tell what at this point. Windows Live, some Antivirus programs, Acronis True Image, Powershell, ATI Control panel, all make changes to the path statement and may need to be re-installed to work properly,

    Best option is to do a system restore to a point before you installed Perl, then re-install Perl.

    Or you can add the default path to what is there now, and re-install any applications/drivers that don't work properly.

    To add this back in:
    Click Start, right click My Computer, click Properties.
    Click the Advanced tab.
    Click the Environment Variables button.
    Under the System variables section, double click PATH.
    Click once in the Variable value: field to select it (do not delete what is already there).
    Press the Home key on the keyboard.
    Type (or copy and paste) the following:
    Code:
    %SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;
    Click OK until you are back at the Desktop.
    Open a new Command Prompt window
    Type PATH, it should now display the default followed by the path to the perl program that is there now:
    Code:
    C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;[COLOR=Red]<path to perl>[/COLOR]
     
  5. arungoogol

    arungoogol Thread Starter

    Joined:
    Mar 2, 2010
    Messages:
    41
    works great,

    thank u genius...
     
  6. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/971182

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice