1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Problem with intel 3945abg & vista

Discussion in 'Windows Vista' started by guerin, Feb 17, 2007.

Thread Status:
Not open for further replies.
Advertisement
  1. guerin

    guerin Thread Starter

    Joined:
    Oct 12, 2004
    Messages:
    18
    Hi hope someone can help me

    I've just bought a Toshiba laptop running windows vista premium. I am trying to use the internal wireless card (Intel PRO/Wireless 3945ABG adapter) to connect to my linksys WRT54G Wireless Router but not having much luck.

    I have 3 other PC's in the house (1 vista ultimate & 2 Win XP Pro) all with linksys adapters connecting without any problems. I have switched off the wpa-psk (TKIP) security to try and fix this problem but it does not seem to help. The laptop connects to the router but does not get a valid IP address (192.168.20.x). Running an ipconfig /all from a command prompt shows the address to be a local 169.254.72.152.

    If you need any more info plaese let me know

    Hope somebody knows a fix for this problem

    Cheers

    Dominic
     
  2. guerin

    guerin Thread Starter

    Joined:
    Oct 12, 2004
    Messages:
    18
    Just tried to connect the laptop via ethernet but no joy either!! Just getting a 169.x.x.x address
     
  3. guerin

    guerin Thread Starter

    Joined:
    Oct 12, 2004
    Messages:
    18
    I have just uninstalled the Vodafone Mobile connect software that I'm using to control my vodafone PC Card (HUAWEI E620) and the Intel wireless card is working again!!

    There is obviously a compatability issue here with the software so will have to talk to vodafone about why this is happening as there software is supposed to work with WLAN cards too!!

    If anyone knows anything about this problem please could they let me know

    Cheers

    Dominic
     
  4. eveen

    eveen

    Joined:
    Jun 27, 2007
    Messages:
    2
    Hi,

    I'm having the same problem with an Acer Travelmate 5623 with Vista Business.
    It has a intel wireless network card (3945) that is working fine with several accesspoints.

    Until... i installed the vodafone mobile connect software (version 9.x.x).
    Then the problems connecting to the accesspoints started. The accesspoint is visible and the network card tries to connect, but it doesn't receive an IP address.

    Uninstalling the vodafone mobile connect software and rebooting the laptop was the only solution I found to connect to the wireless accesspoint.

    Does anybody have a different solution?
     
  5. eveen

    eveen

    Joined:
    Jun 27, 2007
    Messages:
    2
    I found a solution on the internet...

    You need to:
    1. Uninstall Vodafone Mobile Connect Dashboard software v9.x.x
    2. Install Vodafone Mobile Connect Dashboard software v9.x.x
    3. When prompted for "Setup Type" Choose "Custom"
    4. Click "Next" twice to continue
    5. Under "Select Program Features you want Installed" deselect "Optimisation Software"
    6. Complete the installation as normal.

    This worked on my Vista laptop.
    I'm actually typing on it right now with de mobile connect software installed and connected through my wrt54gl.
     
  6. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/544776

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice