1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Problem with my hardware hardware please help

Discussion in 'Hardware' started by Alex108, Jul 10, 2007.

Thread Status:
Not open for further replies.
Advertisement
  1. Alex108

    Alex108 Thread Starter

    Joined:
    Jul 10, 2007
    Messages:
    3
    i have put together a new pc put of these parts

    AMD 64 x2 athlon 5600+, Asus Crosshair motherboard, EZ cool power supply 550W on the 12v it has 36 amp, and i have got a Geforce BFG 8800 GTS OC graphic card, 2 gb of DDR2 elixir brand,

    the problem is when i try to boot it up nothing appears on my screen i dont know what the problem could be, checked all connection everything is connected, including power to the graphic card, maybe it could be DDR or Power supply or simply my grapgic card faulty??

    thanks in advance for any help
     
  2. cornman

    cornman

    Joined:
    Jul 1, 2007
    Messages:
    114
    I am also having that same problem with my new GeForce 6200 but i have no idea how to fix it.
     
  3. me10

    me10

    Joined:
    May 11, 2003
    Messages:
    217
  4. Alex108

    Alex108 Thread Starter

    Joined:
    Jul 10, 2007
    Messages:
    3
    Well what can I say u saved my ***, thak you for the advice my problem was one of the bolts was touching my motherboard from underneath so i got that removed it all worked fine thak u yet again
     
  5. Alex108

    Alex108 Thread Starter

    Joined:
    Jul 10, 2007
    Messages:
    3
    maybe chek your powersupply it has to be over 450 w also chek if u connected the power cable to the card well my problem was on mounting some screw was touching my motherboard which was blocking the signal
     
  6. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/594097

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice