1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Problem with Twitter not opening Links.

Discussion in 'Web & Email' started by mxzh, Mar 22, 2012.

Thread Status:
Not open for further replies.
Advertisement
  1. mxzh

    mxzh Thread Starter

    Joined:
    Mar 22, 2012
    Messages:
    9
    Want to start by saying Hello :D, good looking forum you've got here.

    Ok now my problem, I've asked a friend that knows alot about this but he can't help either. For about 2 weeks now, I can't open any long links on Twitter. I can only open short links which can be highlighted, then right-click and "switch to 'website'".

    For example, I can open this link, because it's short enough to highlight the whole thing and then rightclick:

    [​IMG]

    When there's a long link like this one it won't open, just bring me to a page which says:

    "Oops, Google Chrome couldn't find t.co"

    [​IMG]

    I've checked my Antivirus, Firewall etc and nothing there which would block access to these sites, I've also tried different browsers and it's the same there.

    Any help is appreciated, thanks.
     
  2. mxzh

    mxzh Thread Starter

    Joined:
    Mar 22, 2012
    Messages:
    9
    *bump* 85 Views and no solution? Come on people :[
     
  3. Phantom010

    Phantom010 Trusted Advisor

    Joined:
    Mar 9, 2009
    Messages:
    34,057
    First reply! :D

    Maybe people just don't know the answer. All members are volunteers.

    Besides, the forum is always awfully quiet from Fridays through Mondays. On weekends, seems their spouses won't let them touch the machine! :D

    Seriously, is this happening only on Twitter?

    Can you copy the links and paste them in the address bar instead?
     
  4. mxzh

    mxzh Thread Starter

    Joined:
    Mar 22, 2012
    Messages:
    9
    Thanks for the reply and...sorry for the triple post lol.

    Yeah, only on Twitter, seems to be a problem with their "t.co" shortening service or something, and I can only copy/paste the short links in the address bar, can't copy the long ones because they're not fully shown.
     
  5. Phantom010

    Phantom010 Trusted Advisor

    Joined:
    Mar 9, 2009
    Messages:
    34,057
    Is this happening in Internet Explorer as well?
     
  6. Phantom010

    Phantom010 Trusted Advisor

    Joined:
    Mar 9, 2009
    Messages:
    34,057
    In Internet Explorer at least, you don't need to highlight the URL when right-clicking it. You can simply right-click the link and select Open.
     
  7. Phantom010

    Phantom010 Trusted Advisor

    Joined:
    Mar 9, 2009
    Messages:
    34,057
    Also, the Twitter link service measures information such as how many times a link has been clicked. If you have a security feature blocking Web counters, it may be interfering with the links?
     
  8. mxzh

    mxzh Thread Starter

    Joined:
    Mar 22, 2012
    Messages:
    9
    Happens in all Browsers (IE 64 & 32, Chrome, Firefox and Maxthon). And what exactly do you mean? I have my Firewall and Antivirus disabled and it still doesn't work. I'm not sure but it might've been since I reset my router, could it have something to do with that?
     
  9. Phantom010

    Phantom010 Trusted Advisor

    Joined:
    Mar 9, 2009
    Messages:
    34,057
    Have you tried bypassing the router?
     
  10. mxzh

    mxzh Thread Starter

    Joined:
    Mar 22, 2012
    Messages:
    9
    Can't do that on my own PC cause it's too far away to directly connect to the modem, but I'll try it on my moms PC tomorrow because it's nearly 4am right now lol.
     
  11. Phantom010

    Phantom010 Trusted Advisor

    Joined:
    Mar 9, 2009
    Messages:
    34,057
    OK. Keep us posted. :)
     
  12. mxzh

    mxzh Thread Starter

    Joined:
    Mar 22, 2012
    Messages:
    9
    I've made a thread on here 1-2 weeks ago but it seems it's gone. My original problem was that I couldn't open any shortened links, let it be Twitter (t.co), bit.ly or any of the others. That still isn't fixed but I've found a workaround. Now I have a new problem, which is that my Youtube wont open anymore, same as before, just says the site is unavailable when it works for others. It only doesn't work on Chrome, works in other browsers.
    I've been thinking of a fresh Windows Installation, but would that fix it or does it have something to do with my router etc?
     
  13. TerryNet

    TerryNet Terry Moderator

    Joined:
    Mar 23, 2005
    Messages:
    69,556
    I've merged your threads, since they seem to be closely related and maybe the same issue.

    If the problem occurs with Chrome but not with other browsers why would you suspect Windows or the router?
     
  14. mxzh

    mxzh Thread Starter

    Joined:
    Mar 22, 2012
    Messages:
    9
    Well the Youtube thing only happens on Chrome, the shortened links dont work on any browser.
    Also, I've been getting these logs for a while now, normally the whole thing is full with similar messages, not sure if it has something to do with this or if its a problem

    [​IMG]
     
  15. TerryNet

    TerryNet Terry Moderator

    Joined:
    Mar 23, 2005
    Messages:
    69,556
    The log appears to be from a router [EDIT: I typed modem originally, but I meant to say router]. It looks perfectly normal unless you did not plug in or reset the router at that time displayed. If it is initializing for no good reason there is a problem, but it would be independent of the ones you have reported.

    What's the workaround to the tiny url problem?

    What firewall or security suite (and anti-spyware if different) do you have on the system? I'm thinking that since "disabled" firewalls sometimes interfere with networking anyhow maybe a firewall or anti-spyware is blocking a redirect.

    Suggest that you try a free public DNS server. If this is a DNS issue that will "find" the problem and fix it at the same time.
     
  16. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1046179