1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Problems with MP Navigator on Canon scanner

Discussion in 'Hardware' started by kenneth7379, Jan 23, 2019.

Thread Status:
Not open for further replies.
Advertisement
  1. kenneth7379

    kenneth7379 Thread Starter

    Joined:
    Oct 19, 2008
    Messages:
    206
    First Name:
    Ken
    Having difficulty setting up my Canon LiDE 110 scanner in a Windows 7 64 bit computer. I've loaded the Canon LiDE 110 program, and understand that I need to install MP Navigator. I looked for the program online, and it says I need the 5.0 version of Navigator. I've downloaded it, but it stalls and refuses to open. Although it's the Canon recommended version, when I try to open it, it shows a list of models that it will support, but I can't find my model of scanner listed. I've been practising insanity.....Doing the same thing over and over and expecting a different result. I've got hours and hours invested in this with no success, so I need to ask for help. What I doing wrong?

    Thanks for your help



    Tech Support Guy System Info Utility version 1.0.0.4
    OS Version: Microsoft Windows 7 Professional, Service Pack 1, 64 bit
    Processor: Intel(R) Core(TM) i3-2120 CPU @ 3.30GHz, Intel64 Family 6 Model 42 Stepping 7
    Processor Count: 4
    RAM: 8080 Mb
    Graphics Card: Intel(R) HD Graphics, -1988 Mb
    Hard Drives: C: 224 GB (179 GB Free);
    Motherboard: Hewlett-Packard, 1495
    Antivirus: Malwarebytes, Enabled and Updated
     
  2. lynx1021

    lynx1021

    Joined:
    Jan 7, 2014
    Messages:
    2,433
  3. kenneth7379

    kenneth7379 Thread Starter

    Joined:
    Oct 19, 2008
    Messages:
    206
    First Name:
    Ken
    Thanks for your reply, lynx. I hadn't encountered that version when I searched online.....Mostly 4.0 and 5.0. However, I went to the linked page and downloaded 4.03, but when I tried to use it, it said it was 4.0. Still having the same problem as before - The display says "Release the lock switch, detach the USB cable, and reconnect. Scanner driver will be closed." I've checked, and the lock switch is released, I've disconnected and reconnected the USB cable, and when I start the process over, the same thing happens.
     
  4. lynx1021

    lynx1021

    Joined:
    Jan 7, 2014
    Messages:
    2,433
    Some printer programs require you to have the USB disconnected when you install the program and only connect when it tells you to. I have a cheep Canon Pixima 2500 series and it can't even use MP navigator, it uses image garden.
     
  5. kenneth7379

    kenneth7379 Thread Starter

    Joined:
    Oct 19, 2008
    Messages:
    206
    First Name:
    Ken
    Thanks for the suggestion, Lynx. I know I had the cable connected when I downloaded the program, because (following the instructions) I checked to make sure the scanner was physically unlocked, and then disconnected and reconnected the USB. I need to try what you're suggesting but I've already spent about twelve hours on other computer issues and I'm really burned out, so I'll try your method tomorrow.
     
  6. kenneth7379

    kenneth7379 Thread Starter

    Joined:
    Oct 19, 2008
    Messages:
    206
    First Name:
    Ken
    Lynx, were you referring to reinstalling the driver program for the Lido 110, or the ME Navigator program? I tried reinstalling Navigator 4.3 with the cable disconnected but found it produced the same result. Should I be reinstalling the driver program as well?
     
  7. 8biosdrive

    8biosdrive

    Joined:
    Sep 30, 2014
    Messages:
    148
    I have a Canon Pixma 870 printer. All of the required software, including MP Navigator, came on the cd. Did your scanner not come with a cd? Have you gone to the Canon website or called their technical support?
     
  8. kenneth7379

    kenneth7379 Thread Starter

    Joined:
    Oct 19, 2008
    Messages:
    206
    First Name:
    Ken
    I acquired the scanner used, from a girlfriend who was unable to use it with her new Mac. I only got the unit and the patch cord, but not the CD. Lynx 1921 gave me a link to the Canon site, which provided the driver and MP Navigator programs. I haven't tried calling them yet because my experience has been that US companies generally don't want to deal with Canadians. I guess that'll be the next step though, to call Canon Technical Support.
     
  9. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1222254

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice