1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Problems with USB Video Capture EasyCAP-DC60

Discussion in 'Windows Vista' started by ankna, Mar 16, 2008.

Thread Status:
Not open for further replies.
Advertisement
  1. ankna

    ankna Thread Starter

    Joined:
    Mar 16, 2008
    Messages:
    2
    Hi, I have bought the EasyCap DC60 USB Videograbber; but it doesn't work for me (Windows Vista). It is installed properly, system says it's working... but when I select this video source in Ulead Video Studio, I get the following message (translated from German, so the exact wording might me different...):

    "Could not initialize video capture plugin. It might me used by another program, or the file was moved to another location. Error trying to open the driver. Cannot create video capture filter."

    I have re-installed the driver... no change.
    Video Studio works fine for me with other video sources - e.g. my DV camera over firewire. So there doesn't seem to be an issue with Video Studio installation.

    One other aspect... the little green LED on the DC60 doesn't flash or anything... should it do anything? What is it for?

    Would be great if anyone has an idea on how to get this working...
     
  2. DaveA

    DaveA David Trusted Advisor

    Joined:
    Nov 16, 1999
    Messages:
    11,853
    Are the drivers and software that you installed approved for Vista or are they XP versions?

    If XP, go to the web site and see if the OEM has Vista versions available for download.
     
  3. ankna

    ankna Thread Starter

    Joined:
    Mar 16, 2008
    Messages:
    2
    Hi DaveA,
    yes, the drivers are Vista versions - at least, the box says explitly that it is Vista compatible... and the drivers were installed directly from the CD that came with the video grabber...
     
  4. gavpat

    gavpat

    Joined:
    May 8, 2008
    Messages:
    3
    Hi Ankna
    I have the same problem, when I try to install the EasyCAP, Vista says that it cannot find the driver and asks for the disk, even though the disk is loaded.
    Vista then goes off to find a solution and takes me to MS Technical Information
    "KB 940199 update for Vista" (even though my copy is up to date with SP1 and all current updates), this update faiuls to install saying "Update does not apply to your system"
    Does anyone have any ideas where to go next?
    Best regards
    Gavin
     
  5. mel8again

    mel8again

    Joined:
    Jul 7, 2008
    Messages:
    767

    I have exactly the same problem. Anyone find a solution?
     
  6. gavpat

    gavpat

    Joined:
    May 8, 2008
    Messages:
    3
    Sure looks as though we have all wasted money on the EasyCAP
    Gavin
     
  7. DaveA

    DaveA David Trusted Advisor

    Joined:
    Nov 16, 1999
    Messages:
    11,853
  8. mel8again

    mel8again

    Joined:
    Jul 7, 2008
    Messages:
    767

    Thanks Dave. I downloaded the 116o file as instructed but there was no setup file in it to install it. Using device manager to install the drivers got the same result as before. Did not find drivers. Works great on XP Home on the other computer but not on this Vista 64 bit one. (n)
     
  9. gavpat

    gavpat

    Joined:
    May 8, 2008
    Messages:
    3
    Thanks Dave. I downloaded the stk1160 file and did as the instructions said. It appears to have worked, at least I didn't get " cannot find the driver" message. I have not tried video capture yet but it appears we have a step in the right direction.
    p.s. I'm on Vista Home Premium x64
    Best regards
    Gavin
     
  10. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/693795