Question about win XP mode of Win 7 and network access

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Mitjko

Thread Starter
Joined
Apr 4, 2005
Messages
70
Hello to all,

I have installed windows XP mode for windows 7 and it works fine. I have even installed few apps that were not possible to be installed on win 7. I played with win 7 virtual PC and have few questions:
1. I see that system chosed 120 GB for this virtual Win XP, I was not asked about this and wonder if this could be changed. The originaly C: system partition in win 7 is 300 GB.
2. When I use cmd command in run and type ipconfig, I see that correct IP address is displayed (192.168.1.65) since it works in private network and internet is working OK. But when I try to ping router (192.168.1.1) I get message that "request timed out" occured. Of course, ping works in windows 7, and I have internet access in both win7 and virtual win xp.

Can someone explain me this?

Thank you.
 
Joined
Nov 2, 2011
Messages
1
Mitjko,
1. The 126GB Hard disk size is the maximum disk size that the virtual machine can use, however the current size should be much less. To see how much space the XP mode VM is actually using, open Windows Explorer and navigate to the Virtual Machines directory in your user directory (In Windows 7, C:\users\<your profile name>\Virtual Machines). You should see your Virtual Machine in here. Please right-click on the virtual machine and click ‘Settings’. On the left, choose ‘Hard Disk 1’ and then you will see both the current disk size and the total disk size.
Windows XP mode works on a read-only base VHD and a differences file. You cannot change it to a fixed disk size directly because of this. There is a discussion in the TechNet forums where some people have figured out a way around this, but beware that this is unsupported. http://social.technet.microsoft.com/Forums/en-AU/w7itprovirt/thread/8ae6dc1e-126f-46ed-a384-224f40f46d69

2. While you are in the VM settings, on the left side, click on ‘Networking’. You will see that the default adapter is ‘Shared Networking (NAT)’. Change this to the actual network adapter in your machine and when you start XP Mode again, you should be able to ping your router.
Hope this helps,
David
Windows Outreach Team – IT Pro
http://www.microsoft.com/springboard
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top