1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

RAM issue or is it?

Discussion in 'Hardware' started by Zippyo3, Jun 26, 2010.

Thread Status:
Not open for further replies.
Advertisement
  1. Triple6

    Triple6 Rob Moderator

    Joined:
    Dec 26, 2002
    Messages:
    45,618
    The motherboard uses a 24 pin power connector, you need a matching high quality 24 pin power supply such as an Antec, Corsair, Enermax, or OCZ to name a few of the better brands. I'd also recommend a 400 watt or higher unit to allow head room and upgradability, or 450 watt or higher if it'll ever be used with a mid to high range video card.
     
  2. Bernardo

    Bernardo

    Joined:
    Jan 8, 2006
    Messages:
    4,221
    Yeah, you need to get a 24 pin PS. Sometimes the 20 will power it up, sometimes not.
     
  3. Zippyo3

    Zippyo3 Thread Starter

    Joined:
    Apr 18, 2010
    Messages:
    58
    hmm ok so you think the power supply could me a reason for the boot thing? still doesent explain why when you remove the ram the system seems to have ample power
     
  4. Triple6

    Triple6 Rob Moderator

    Joined:
    Dec 26, 2002
    Messages:
    45,618
    Without the RAM the system isn't completely posting, it can act different. Plus the RAM does use power as well. You could have more then one issue, but you should replace the PSU with the proper one. The 24 pin connector is required for proper and stable operation of the system.
     
  5. Bernardo

    Bernardo

    Joined:
    Jan 8, 2006
    Messages:
    4,221
    Without ram, it's not trying to boot.
     
  6. Zippyo3

    Zippyo3 Thread Starter

    Joined:
    Apr 18, 2010
    Messages:
    58
    Hmmm ok let me look around for a half decent cheap psu, and ill sort out RAM with that, I'm looking for something at 450W Right and 24 Pin?
     
  7. Bernardo

    Bernardo

    Joined:
    Jan 8, 2006
    Messages:
    4,221
    Yes, and a quality name.
     
  8. Bernardo

    Bernardo

    Joined:
    Jan 8, 2006
    Messages:
    4,221
  9. Triple6

    Triple6 Rob Moderator

    Joined:
    Dec 26, 2002
    Messages:
    45,618
  10. Bernardo

    Bernardo

    Joined:
    Jan 8, 2006
    Messages:
    4,221
  11. Triple6

    Triple6 Rob Moderator

    Joined:
    Dec 26, 2002
    Messages:
    45,618
  12. Zippyo3

    Zippyo3 Thread Starter

    Joined:
    Apr 18, 2010
    Messages:
    58
    Great guys thanks, ill keep an eye open for these, sadly newegg doesent ship to UK
     
  13. Zippyo3

    Zippyo3 Thread Starter

    Joined:
    Apr 18, 2010
    Messages:
    58
    Hmm ok so the New PSU came thismorning, got it installed, and BAM, still the same problem. New ram will arrive either later today or tomorrow so im hoping so much that that will fix it.
     
  14. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/931623