1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Ran CHKDSK /R for Missing or Corrupt Registry File, Now Have an HDD Issue

Discussion in 'Windows XP' started by AggieRob93, Feb 23, 2013.

Thread Status:
Not open for further replies.
  1. AggieRob93

    AggieRob93 Thread Starter

    Joined:
    Feb 23, 2013
    Messages:
    1
    Good morning/afternoon/evening.

    Will try to keep this as short as possible.

    Have a Dell Dimension E510 desktop with a 150gb hdd I partitioned when the computer was purchased in 2007. C:\ was sized to approx 30gb, and D:\ was sized to approx 120gb. Now, onto my current problem(s):


    10 days ago, my desktop presented the following after a reboot:

    "Windows could not start because the following file is missing or corrupt: WINDOWS\SYSTEM32\CONFIG\SYSTEM". This also coincided with a power supply failure shortly thereafter, which has been replaced.

    After replacing the power supply, the above error would still display after reboot. I attempted/completed the following:

    1. Tapped the F8 key to get to the ADVANCED BOOT MENU, and tried the LAST KNOWN GOOD CONFIGURATION option - to no avail. Still received the file missing or corrupt error.

    2. Tried to get to SAFE MODE WITH COMMAND PROMPT from the ADVANCED BOOT MENU, but it would still result in the file missing or corrupt error.

    3. Inserted the OEM OS disk and booted from there. The Windows XP Setup window appeared, with this:

    "To Set up Windows XP now, press ENTER."
    "To repair a Windows XP installation using Recovery Console, press R."
    "To quit Setup without installing Windows XP, press F3."

    I selected and pressed the <R> key to enter the Recovery Console. This got me to:
    C:\WINDOWS\

    I typed:
    chkdsk /r
    and hit <ENTER>

    The result was several (4?) files were repaired, and I then exited and tried a reboot. The same missing or corrupt file message was given, so I ran through the procedure again from the OEM XP cd. This time all was clear.

    I performed a reboot, and Windows slowly came around. I thought all as well, until I tried to access a folder on the D:\ partition. I tried to open the the partition to access it contents, and was presented with the following:
    "The disk in drive D is not formatted. Would you like to format it now?"

    The response from me is "no".

    All data that was in the C:\ partition before the problem seems to be there. The D:\ partition, which had probably 30-40gb of data, shows to be completely empty. When using disk management, the D:\ partition shows as healthy, but the the file system for this partition is empty (no NTFS or FAT). The partition shows to have 119.70gb of available space....not good for the ol' ticker.

    I have Ubuntu 12.0 loaded onto a CD to attempt a retrieve of the data on the D:\ partition. Is this the recommended next step, or should I try something else?
     
  2. drmacpccom

    drmacpccom

    Joined:
    Feb 22, 2013
    Messages:
    59
    Ubuntu is a good approach. If that does not work, I would take the drive and put it into another computer that works (setup as a slave drive) and move data important from both partitions to a new backup medium. I hope this information helps.
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Similar Threads - CHKDSK Missing Corrupt
  1. Robertico22
    Replies:
    8
    Views:
    608
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1090696

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice