Random applications freeze at random times

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Lovrin

Thread Starter
Joined
Mar 26, 2008
Messages
4
The other day, I installed Service Pack 1 for Windows Vista. Since about 2 days after I did, applications have started freezing randomly. I'm not sure it's the SP that's doing this to me though, cause it was a few days after I installed it and not right away. In Task Manager, there are less processes, which is weird. I could be doing anything and the application will freeze out of nowhere and I have to restart my computer to fix it. It's a hassle because sometimes I'm in the middle of something and it does this to me. Has anyone else experienced this problem? Does anybody know if there is a fix for it?
 
Joined
Mar 18, 2008
Messages
458
This can be caused by a host of different things.

Here's what I would do first:

1. Scan for viruses or any type of malware.
2. Update all of my drivers for my network card, video card, sound card.
3. Uninstall any programs I either don't need or don't recognize in Add/Remove programs
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Top