1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Really Technical question about MDAC & JET

Discussion in 'Windows XP' started by bossmoss, May 7, 2001.

Thread Status:
Not open for further replies.
  1. bossmoss

    bossmoss Thread Starter

    Joined:
    May 7, 2001
    Messages:
    1
    I am using a program (which I didn't write) which creates a database driven website. It was working well, but suddenly, when I try to add new records, I get errors. I have the system on a WIN2000 server, and also mirrored on my WIN98 system at home.

    On the WIN2000 server, I get this error message: "ERROR: Multiple-step OLE DB operation generated errors. Check each OLE DB status value, if available. No work was done."

    On the WIN98 system, I get this error: "Errors Occurred"

    In both cases, the record does get added, but it cannot be edited - only deleted.

    Since I couldn't reach the guy who wrote the program I was using, I did some research, and found this page over at Microsoft:

    http://support.microsoft.com/support/kb/articles/q228/9/35.asp

    It described this error exactly. It said I needed to upgrade my MDAC and JET versions to make these errors go away. I don't really know what MDAC and JET are, but I found them for download on Microsoft's site.

    Using my WIN98 system as the guinea pig, I downloaded and installed MDAC 2.6 and JET 4.0 - the most recent versions of both. Needless to say, it didn't fix the problem.

    The only thing that changed on my WIN98 system is that instead of getting the "Errors Occurred" message, I now get the much longer error message that my server returns.

    I haven't tried upgrading the server because - well - I'm afraid to touch the server, especially when the fix didn't work on my local system. Some other pages I found suggested that installing WIN2000 Service Pack 1 would fix the problem on my server, but I haven't tried this yet, as this supposedly only upgrades MDAC/JET too. Besides, while this may fix my server, it still doesn't solve my WIN98 problem.

    Sorry for the long explanation. Any help would be appreciated.
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/43508

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice