1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Recently upgraded cpu and now I get no display but fans spin

Discussion in 'Hardware' started by BenWh, Aug 15, 2019.

Advertisement
  1. BenWh

    BenWh Thread Starter

    Joined:
    Aug 15, 2019
    Messages:
    1
    I recently upgraded from a ryzen 5 1600 to a 3600 and whenever I try to boot, the fans spin and the monitor is blank. I’ve tried using both my graphics card and on board graphics but it still doesn’t work. Because I’m an idiot, I bent pins whilst removing my old cpu, so I can’t check to see if that works. Any help/ suggestions would be greatly appreciated, Ben
     
  2. crjdriver

    crjdriver Moderator

    Joined:
    Jan 2, 2001
    Messages:
    38,968
    First of all, we have no idea what motherboard you are using. Post the exact motherboard AND what bios version you are running. Unless you have one of the new x570 chipset boards [and those do not generally support first gen ryzen] you must do a bios update prior to installing the 3xxx series processor.
     
    lynx1021 likes this.
  3. crjdriver

    crjdriver Moderator

    Joined:
    Jan 2, 2001
    Messages:
    38,968
    BTW if your hsf/cooler is stuck on the processor when you try and remove it, here is how to do it without breaking anything.
    1 System OFF unlock the cam lock and remove the clips
    2 Leave the fan lead connected for now. You have the retaining clips OFF and the cooler still stuck on the processor
    3 Pw ON for at least 1~2min. Now shutdown and give the cooler a gentle twist. It will lift right off
     
    lynx1021 likes this.
  4. crjdriver

    crjdriver Moderator

    Joined:
    Jan 2, 2001
    Messages:
    38,968
    In addition to the above, you may have broken a pin OFF and it is still in the socket. Be sure and turn the board upside down with the lever lock in the release position.

    Note AMD has a loaner program where they will ship you a processor that will allow you to update the bios on your board. Quite nice of them to offer this service.
    You can try using the onboard video until the cows come home; the 3600 does not have video. The video port you see on the motherboard is to support the APU series of processors and the very few ryzen that actually do have onchip video.
     
    SarahSims and lynx1021 like this.
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...

Short URL to this thread: https://techguy.org/1231536

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice