1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Recycle Bin Deletion Error

Discussion in 'Windows XP' started by Boo_Compaq, Apr 7, 2004.

Thread Status:
Not open for further replies.
Advertisement
  1. Boo_Compaq

    Boo_Compaq Thread Starter

    Joined:
    May 9, 2003
    Messages:
    106
    Hey everyone...

    I got a problem with my recycle bin in Win XP (everything is updated). I didnt change any settings, and as far as i know, no one else did either. For some reason, when i delete a file, it asks for confirmation to DELETE, but does NOT put the file in the bin...it just deletes it. I already checked the bin properties, and bypassing is NOT checked off. I've tried searching the registry, searching the net to fix it, but nothing.

    Hope someone can help :(

    Thanx
     
  2. Elvandil

    Elvandil

    Joined:
    Aug 1, 2003
    Messages:
    51,988
    How does the confirmation dialog read? Does it ask if you want to move to the Recycle Bin or does it say "Are you sure you want to delete...."? For an example of what I mean, find a file to delete. Right-click it and hold the Shift key while you click Delete. Is this the message you get?

    This can happen if the permissions assigned to the Recycle Bin are too restrictive. Network files are not deleted to the bin, for example.

    Are you using Home or Pro?

    The box you unchecked (for all drives on the properties page if configured independently) was:
    "Do not move files to the Recycle Bin. Remove files immediately when deleted"?

    Also be sure you have allotted a reasonable percentage of your drive for deleted files, like 5-10%.
     
  3. Boo_Compaq

    Boo_Compaq Thread Starter

    Joined:
    May 9, 2003
    Messages:
    106
    Yes the message is to DELETE the files (same message as shift+del) and not to move to recycle bin. I am using Windows XP PRO. The space allotted for my recycle bin is 5% of the drive (80 GB..i was testing just simple document files and copies of a couple bigger files), and i made sure that the box that says "Do not move files to the Recycle Bin. Remove files immediately when deleted." was NOT checked (so i dont have it set to bypass the recycle bin).

    I have heard about the permissions for the recycle bin, but i am not on a network. This is a 2 user computer home computer. I have my account which is separate from my family's account. Both have admin privileges, but as far as i know they didnt change anything (their knowledge of how to use a computer is very basic). If this is indeed the problem, could you let me know how to change it back to normal?

    Thanks
     
  4. Elvandil

    Elvandil

    Joined:
    Aug 1, 2003
    Messages:
    51,988
    This article is not for XP, but the same procedure and permissions apply:
    Files Do Not Show Up in Recycle Bin When Deleted

    You might also try checking the policy.

    Go to Start >Run, and type:
    gpedit.msc
    OK

    Navigate to:

    Local Computer Policy > User Configuration > Admin Templates > Windows Components > Windows Explorer.

    In the right pane, double-click:

    "Do not move deleted files to the recycle bin".

    Be sure it is disabled or unconfigured.
     
  5. Boo_Compaq

    Boo_Compaq Thread Starter

    Joined:
    May 9, 2003
    Messages:
    106
    I already read that ms report and tried that, but i do not have ownership options, nor do i have a C:\Recycled folder. As for the policy, i checked it out, and it was unconfigured...so i disabled it, but still no change. Is there by any chance a way to completely fix any problem related to the recycle bin? ive heard about booting into command line and using deltree on recycle bin, but i dont know if that will fix my problem, or if that is advisable.
     
  6. Elvandil

    Elvandil

    Joined:
    Aug 1, 2003
    Messages:
    51,988
    The folder in XP should be C:\Recycler. It is hidden so you need to show hidden files and folders in Folder Options in the Control Panel. Is it there?

    You have ownership options on that folder (and any others on other drives if you have any).
     
  7. Boo_Compaq

    Boo_Compaq Thread Starter

    Joined:
    May 9, 2003
    Messages:
    106
    Ah well thats why i couldnt get into C:\Recycled...doesnt exist lol. Well i checked out recycleR, and i still dont have any options for ownership (the tab doesnt even exist, and there are no buttons for it) :mad: . I have, however, noticed that when i go into it, it is marked with a dash (-) on read only. So if i uncheck it, it re-checks itself after i apply the change, hit ok, then go back into it.
     
  8. stu37

    stu37

    Joined:
    Jun 9, 2002
    Messages:
    562
    Try this repair that is from Kelly's Corner:for xp home, not sure about pro

    http://www.kellys-korner-xp.com/reg...erecyclebin.reg

    The last person I sent that link to got it to work but had to do the following ritual. First run the repair file and affirm the changes. Then dump the Recycle Bin and reboot. Then run the repair file once more. Then dump the Recycle Bin if it allows. If it has nothing in it, try deleting some trash file and see if it now shows up.

    The crux of the issue was multiple reboots, dumps, and executions as I recall.

    Maybe it was running the repair file after dumping the Bin, try that also.

    Post back any results.
     
  9. stu37

    stu37

    Joined:
    Jun 9, 2002
    Messages:
    562
  10. Boo_Compaq

    Boo_Compaq Thread Starter

    Joined:
    May 9, 2003
    Messages:
    106
    Yeah i already tried that fix...didnt work...tried again..didnt work...thanx for tryin tho lol...this is a pain in the butt now. :eek:
     
  11. Boo_Compaq

    Boo_Compaq Thread Starter

    Joined:
    May 9, 2003
    Messages:
    106
    bumpy bumpy
     
  12. Boo_Compaq

    Boo_Compaq Thread Starter

    Joined:
    May 9, 2003
    Messages:
    106
    suuuuper bump...this is kind of an important issue....i dont want to have to worry about every little delete (or go through the pain of file recovery)....someone has to have some kind of solution...least id hope so
     
  13. Elvandil

    Elvandil

    Joined:
    Aug 1, 2003
    Messages:
    51,988
    OK. You need to make that Security tab appear. Go to Folder Options in Control Panel, View tab and uncheck the option about Simple File Sharing. Apply, and you should have your Security tab. Take a look at the permissions you have and see how they compare to those in the article.
     
  14. rude

    rude

    Joined:
    Mar 8, 2004
    Messages:
    2,326
    [Start] [Run] [Regedit]
    Registry Key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\BitBucket
    Modify/Create the Value Data Type(s) and Value Name(s) as detailed below.
    Data Type: DWORD // Value Name: NukeOnDelete
    Setting for Value Data: [0 = Use Recycle Bin / 1 = Permanently Delete]
    Exit Registry and Reboot
     
  15. Boo_Compaq

    Boo_Compaq Thread Starter

    Joined:
    May 9, 2003
    Messages:
    106
    Thanks for the help guys, but i got it fixed. I found a registry fix 'no nuke on delete' or something (EDIT: lol...same thing you were talking about rude..thanx :)). Dunno why none of the other ones didnt work....

    Also thanks elvan...i got the security tabs now :D
     
  16. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/217927

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice